diff options
author | Jari Aalto <jari.aalto@cante.net> | 2010-05-05 03:13:42 +0300 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:43 -0800 |
commit | 61af55884cfcb2ac70f42a9fc8dc68b3c343b402 (patch) | |
tree | 7159ecad56e23911f4c869d2f2e076c382378157 /guile.init | |
parent | 3f111dfa0c6ef68339f1a5086342a53a66a4c57a (diff) | |
download | slib-61af55884cfcb2ac70f42a9fc8dc68b3c343b402.tar.gz slib-61af55884cfcb2ac70f42a9fc8dc68b3c343b402.zip |
Import Debian changes 3b1-3.1debian/3b1-3.1
slib (3b1-3.1) unstable; urgency=low
[ Jari Aalto ]
* Non-maintainer upload.
- Move to packaging format "3.0 (quilt)".
* debian/compat
- Update to 7.
* debian/control
- (Build-Depends-Indep): Update to debhelper 7.1.
- (Depends): add ${misc:Depends}.
- (Homepage): New field.
- (Standards-Version): update to 3.8.4.
+ slib
- (Depends): add ${misc:Depends}, install-info.
- (Priority): remove inherited field.
- (Section): remove inherited field.
* debian/copyright
- Update "more information" URL.
* debian/doc-base
- (Section): Remove obsolete top-level "Apps/".
* debian/prerm
- Remove path component from commands.
- Remove obsolete install-docs, install-info commands.
* debian/postinst
- Remove obsolete install-docs, install-info commands.
- Remove path component from commands.
* debian/source/format
- New file.
* debian/watch
- New file.
[ Hideki Yamane (Debian-JP) <henrich@debian.or.jp> ]
* debian/rules
- (build): Rewrite make calls.
- (binary-indep:): install *.html not slib/*.html to fix. It is
useless to specify htmllib (FTBFS; Closes: #552911).
Diffstat (limited to 'guile.init')
-rw-r--r-- | guile.init | 23 |
1 files changed, 10 insertions, 13 deletions
@@ -43,17 +43,17 @@ ;;; (implementation-vicinity) should be defined to be the pathname of ;;; the directory where any auxillary files to your Scheme ;;; implementation reside. -(define implementation-vicinity - (let* ((path (or (%search-load-path "ice-9/q.scm") - (error "Could not find ice-9/q.scm in " %load-path))) - (vic (substring path 0 (- (string-length path) 11)))) - (lambda () vic))) +;; (define implementation-vicinity +;; (let* ((path (or (%search-load-path "ice-9/q.scm") +;; (error "Could not find ice-9/q.scm in " %load-path))) +;; (vic (substring path 0 (- (string-length path) 11)))) +;; (lambda () vic))) ;; ;;; Rob Browning says %site-dir exists since Guile-1.6 -;;(define implementation-vicinity -;; (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH")) -;; => (lambda (path) (lambda () path))) -;; (else %site-dir))) +(define implementation-vicinity + (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH")) + => (lambda (path) (lambda () path))) + (else %site-dir))) ;;; (library-vicinity) should be defined to be the pathname of the ;;; directory where files of Scheme library functions reside. @@ -68,10 +68,7 @@ (and path (substring path 0 (- (string-length path) 10)))) ;; Use this path if your scheme does not support GETENV ;; or if SCHEME_LIBRARY_PATH is not set. -;; Changed from /usr/lib/slib to /usr/share/slib by tb@debian.org for -;; Debian packaging. -;; "/usr/lib/slib/" - "/usr/share/slib/" + "/usr/lib/slib/" (in-vicinity (implementation-vicinity) "slib/")))) (lambda () library-path))) |