aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJames LewisMoss <dres@debian.org>2001-07-27 23:45:29 -0400
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:29 -0800
commitf559c149c83da84d0b1c285f0298c84aec564af9 (patch)
treef1c91bcb9bb5e6dad87b643127c3f878d80d89ee /debian/rules
parentc394920caedf3dac1981bb6b10eeb47fd6e4bb21 (diff)
parent87b82b5822ca54228cfa6df29be3ad9d4bc47d16 (diff)
downloadslib-f559c149c83da84d0b1c285f0298c84aec564af9.tar.gz
slib-f559c149c83da84d0b1c285f0298c84aec564af9.zip
Import Debian changes 2d2-1debian/2d2-1
slib (2d2-1) unstable; urgency=low * New upstream version * Revert back to free. Is now so. slib (2d1-1) unstable; urgency=low * New upstream version. * Move to non-free. FSF pointed out license doesn't allow modified versions to be distributed. * Get a complete list of copyrights that apply to the source into copyright file. * Remove setup for guile 1.3. * Remove postrm. Just calling install-info (lintian) Move install-info call to prerm since doc-base doesn't do install-info. slib (2c9-3) unstable; urgency=low * Change info location to section "The Algorithmic Language Scheme" to match up with where guile puts it's files. * Postinst is running slibconfig now. (Closes: #75891) slib (2c9-2) unstable; urgency=low * Stop installing slibconfig (for guile). * In postinst if /usr/sbin/slibconnfig exists call it (Close: #75843 #75891). slib (2c9-1) unstable; urgency=low * New upstream (Closes: #74760) * replace string-index with strsrch:string-index in http-cgi.scm. * Add doc-base support (Closes: #31163)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 6 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 1a8c9a9..f690acd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -40,7 +40,6 @@ binary-indep: checkroot build
$(INSTALL_DIR) debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/prerm debian/tmp/DEBIAN
- $(INSTALL_PROGRAM) debian/postrm debian/tmp/DEBIAN
# library
$(INSTALL_DIR) debian/tmp/usr/share/slib
@@ -66,6 +65,9 @@ binary-indep: checkroot build
$(INSTALL_DIR) debian/tmp/usr/share/slib/init
$(INSTALL_DATA) *.init debian/tmp/usr/share/slib/init
+ $(INSTALL_DIR) debian/tmp/usr/share/doc-base
+ $(INSTALL_DATA) debian/doc-base debian/tmp/usr/share/doc-base/slib
+
# info pages
$(INSTALL_DIR) debian/tmp/usr/share/info
$(INSTALL_DATA) slib.info* debian/tmp/usr/share/info
@@ -73,10 +75,10 @@ binary-indep: checkroot build
# slibconfig
- $(INSTALL_DIR) debian/tmp/usr/sbin
- $(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
+ #$(INSTALL_DIR) debian/tmp/usr/sbin
+ #$(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
- dpkg-gencontrol
+ dpkg-gencontrol -is -ip
dpkg --build debian/tmp ..
define checkdir