aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2006-10-24 17:45:55 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:37 -0800
commit9759d086b03352d87bb7b536132d3ef731cdbc3c (patch)
treec6b54bef66f3006b9aefb6a7aac2a474ad282a92
parent97fc07b2d8896b869db55827900f24e6528a9bd6 (diff)
downloadslib-9759d086b03352d87bb7b536132d3ef731cdbc3c.tar.gz
slib-9759d086b03352d87bb7b536132d3ef731cdbc3c.zip
Import Debian changes 3a4-2debian/3a4-2
slib (3a4-2) unstable; urgency=low * guile.init (library-vicinity): Set default location of slib to /usr/share/slib instead of /usr/lib/slib. * RScheme.init (library-vicinity): Likewise. * require.scm: Work around the fact that scm versions < 5e3 set *features* but not slib:features.
-rw-r--r--RScheme.init2
-rw-r--r--debian/changelog11
-rw-r--r--guile.init2
-rw-r--r--require.scm7
4 files changed, 20 insertions, 2 deletions
diff --git a/RScheme.init b/RScheme.init
index 544bca1..4f80b41 100644
--- a/RScheme.init
+++ b/RScheme.init
@@ -48,7 +48,7 @@
;; Use this path if your scheme does not support GETENV
;; or if SCHEME_LIBRARY_PATH is not set.
(case (software-type)
- ((unix) "/usr/lib/slib/")
+ ((unix) "/usr/share/slib/")
((vms) "lib$scheme:")
((ms-dos) "C:\\SLIB\\")
(else "")))))
diff --git a/debian/changelog b/debian/changelog
index cbaf603..e4ee187 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+slib (3a4-2) unstable; urgency=low
+
+ * guile.init (library-vicinity): Set default location of slib to
+ /usr/share/slib instead of /usr/lib/slib.
+ * RScheme.init (library-vicinity): Likewise.
+
+ * require.scm: Work around the fact that scm versions < 5e3 set
+ *features* but not slib:features.
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Tue, 24 Oct 2006 17:45:55 -0700
+
slib (3a4-1) unstable; urgency=low
* New upstream release.
diff --git a/guile.init b/guile.init
index 9cf6ed4..412a6b4 100644
--- a/guile.init
+++ b/guile.init
@@ -58,7 +58,7 @@
(and (defined? 'getenv) (getenv "SCHEME_LIBRARY_PATH"))
;; Use this path if your scheme does not support GETENV
;; or if SCHEME_LIBRARY_PATH is not set.
- "/usr/lib/slib/"
+ "/usr/share/slib/"
(in-vicinity (implementation-vicinity) "slib/"))))
(lambda () library-path)))
diff --git a/require.scm b/require.scm
index 31d922d..d9edb91 100644
--- a/require.scm
+++ b/require.scm
@@ -19,6 +19,13 @@
;@
(define *slib-version* "3a4")
+;;;; Accommodate scm versions < 5e3 which set *features* but not
+;;;; slib:features
+;;;; -- tb@debian.org, 10/24/2006
+(if (and (eq? (scheme-implementation-type) 'SCM)
+ (not (defined? slib:features)))
+ (define slib:features *features*))
+
;;;; MODULES
;@
(define *catalog* #f)