aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarl Sackett <krs@debian.org>1996-12-16 09:23:46 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:26 -0800
commit3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (patch)
treeed2973bb627a6461135f273099a95ff6bb8278fc
parent8ffbc2df0fde83082610149d24e594c1cd879f4a (diff)
downloadslib-3796d2595035e192ed4bf1c9a6bfdb13c3c9d261.tar.gz
slib-3796d2595035e192ed4bf1c9a6bfdb13c3c9d261.zip
Import Debian changes 2a6-1debian/2a6-1
slib (2a6-1) unstable; urgency=low * First Debian release.
-rw-r--r--debian/changelog9
-rw-r--r--debian/control14
-rw-r--r--debian/copyright14
-rw-r--r--debian/postinst6
-rw-r--r--debian/postrm4
-rwxr-xr-xdebian/rules86
6 files changed, 133 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2b01f25
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+slib (2a6-1) unstable; urgency=low
+
+ * First Debian release.
+
+ -- Karl Sackett <krs@debian.org> Mon, 16 Dec 1996 09:23:46 -0600
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c262c5c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: slib
+Section: devel
+Priority: optional
+Maintainer: Karl Sackett <krs@debian.org>
+Standards-Version: 2.1.1.2
+
+Package: slib
+Architecture: all
+Description: Portable Scheme library.
+ SLIB is a portable scheme library meant to provide compatibiliy and
+ utility functions for all standard scheme implementations. SLIB
+ includes initialization files for Chez, ELK 2.1, GAMBIT, MacScheme,
+ MITScheme, scheme->C, Scheme48, T3.1, and VSCM. SCM also supports
+ SLIB.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f2b5931
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,14 @@
+This is the Debian GNU/Linux prepackaged version of slib.
+
+This package was put together by Karl Sackett <krs@debian.org>,
+from sources obtained from:
+
+ ftp://swiss-ftp.ai.mit.edu/archive/scm/slib2a6.tar.gz
+
+For more information see:
+
+ http://www-swiss.ai.mit.edu/~jaffer/SLIB.html
+
+License:
+
+scm is distributed under the GNU General Public License.
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..de5756a
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,6 @@
+#!/bin/sh
+set -e
+#
+install-info --quiet --section "Development" "Development" \
+ --description="The SLIB portable Scheme library" \
+ /usr/info/slib.info.gz
diff --git a/debian/postrm b/debian/postrm
new file mode 100644
index 0000000..18f9b39
--- /dev/null
+++ b/debian/postrm
@@ -0,0 +1,4 @@
+#!/bin/sh
+set -e
+#
+install-info --quiet --remove slib
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f36c459
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,86 @@
+#! /usr/bin/make -f
+#
+
+CC =gcc
+CFLAGS =-O2 -g -Wall
+LDFLAGS =
+
+SHELL =/bin/sh
+srcdir =.
+
+INSTALL =/usr/bin/install
+INSTALL_DIR =$(INSTALL) -d -m 755 -o root -g root
+INSTALL_PROGRAM =$(INSTALL) -m 755 -o root -g root
+INSTALL_DATA =$(INSTALL) -m 644 -o root -g root
+INSTALL_MAN =$(INSTALL) -m 444 -o root -g root
+
+config:
+ $(checkdir)
+ touch stamp-config
+
+build:
+ $(checkdir)
+ test -f stamp-config || make -f debian/rules config
+ make
+ texi2html -monolithic slib.texi
+ touch stamp-build
+
+clean:
+ $(checkdir)
+ test -f stamp-config || make -f debian/rules config
+ -rm slib.html
+ make clean
+ -rm -f stamp-config stamp-build
+ -rm -rf debian/tmp* debian/files debian/substvars
+
+binary-arch: checkroot
+ $(checkdir)
+
+binary-indep: checkroot
+ $(checkdir)
+ -rm -rf debian/tmp*
+ test -f stamp-build || make -f debian/rules build
+#
+#
+# debian/tmp
+ $(INSTALL_DIR) debian/tmp
+ $(INSTALL_DIR) debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/postrm debian/tmp/DEBIAN
+# library
+ $(INSTALL_DIR) debian/tmp/usr/lib/slib
+ $(INSTALL_DATA) *.scm debian/tmp/usr/lib/slib
+# documentation
+ $(INSTALL_DIR) debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) debian/copyright debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) debian/changelog \
+ debian/tmp/usr/doc/slib/changelog.Debian
+ gzip -9 debian/tmp/usr/doc/slib/changelog.Debian
+#
+ $(INSTALL_DATA) ChangeLog debian/tmp/usr/doc/slib
+ gzip -9 debian/tmp/usr/doc/slib/ChangeLog
+ $(INSTALL_DATA) README debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) FAQ debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) slib.html debian/tmp/usr/doc/slib
+#
+ $(INSTALL_DIR) debian/tmp/usr/doc/slib/init
+ $(INSTALL_DATA) *.init debian/tmp/usr/doc/slib/init
+# info pages
+ $(INSTALL_DIR) debian/tmp/usr/info
+ $(INSTALL_DATA) slib.info* debian/tmp/usr/info
+ gzip -9 debian/tmp/usr/info/*
+#
+ dpkg-gencontrol -isp -pslib -Pdebian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f slib.texi -a -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: config build clean binary binary-arch binary-indep