summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2006-09-11 22:48:39 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commitd88166ea96a5df05896f7752519a7b159019efe6 (patch)
treef7ae13949b04545d5f3bf926e47c95d04f56c5a5
parent7f1594d11d65ef86ecc41748619b2bd98c2c36ba (diff)
downloadslib-d88166ea96a5df05896f7752519a7b159019efe6.tar.gz
slib-d88166ea96a5df05896f7752519a7b159019efe6.zip
Import Debian changes 3a3-3debian/3a3-3
slib (3a3-3) unstable; urgency=low * slib.texi (Library Catalogs): Mention that a suffix (such as ".scm") may be appended to the filename on some systems. (Closes: #147477) * postinst, prerm: Just know that install-docs is in /usr/sbin. (Closes: #293047) * debian/rules (binary-indep): Install slib.sh as /usr/bin/slib program. (Closes: #301437) * getopt.scm (*argv*): Comment out declaration. (Closes: #248781)
-rw-r--r--debian/changelog15
-rw-r--r--debian/postinst4
-rw-r--r--debian/prerm4
-rwxr-xr-xdebian/rules4
-rw-r--r--getopt.scm2
-rw-r--r--slib.texi7
6 files changed, 30 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index d367337..b15c7a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+slib (3a3-3) unstable; urgency=low
+
+ * slib.texi (Library Catalogs): Mention that a suffix (such as ".scm")
+ may be appended to the filename on some systems. (Closes: #147477)
+
+ * postinst, prerm: Just know that install-docs is in /usr/sbin.
+ (Closes: #293047)
+
+ * debian/rules (binary-indep): Install slib.sh as /usr/bin/slib program.
+ (Closes: #301437)
+
+ * getopt.scm (*argv*): Comment out declaration. (Closes: #248781)
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Mon, 11 Sep 2006 22:48:39 -0700
+
slib (3a3-2) unstable; urgency=low
* debian/postinst: If scm is installed, rebuild its slib catalog.
diff --git a/debian/postinst b/debian/postinst
index 7aa2898..ea573b7 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -33,7 +33,7 @@ fi
# doc base support
if [ "$1" = configure ]; then
- if command -v install-docs >/dev/null 2>&1; then
- install-docs -i /usr/share/doc-base/slib
+ if test -x /usr/sbin/install-docs >/dev/null 2>&1; then
+ /usr/sbin/install-docs -i /usr/share/doc-base/slib
fi
fi
diff --git a/debian/prerm b/debian/prerm
index 3dbde02..4e94192 100644
--- a/debian/prerm
+++ b/debian/prerm
@@ -8,8 +8,8 @@ fi
# doc base support
if [ "$1" = remove -o "$1" = upgrade ]; then
- if command -v install-docs >/dev/null 2>&1; then
- install-docs -r slib
+ if test -x /usr/sbin/install-docs >/dev/null 2>&1; then
+ /usr/sbin/install-docs -r slib
fi
fi
diff --git a/debian/rules b/debian/rules
index b6ad478..e8af261 100755
--- a/debian/rules
+++ b/debian/rules
@@ -92,6 +92,10 @@ binary-indep: checkroot build
#$(INSTALL_DIR) debian/tmp/usr/sbin
#$(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
+# program
+ $(INSTALL_DIR) debian/tmp/usr/bin
+ $(INSTALL_PROGRAM) slib.sh debian/tmp/usr/bin/slib
+
dpkg-gencontrol -is -ip
dpkg --build debian/tmp ..
diff --git a/getopt.scm b/getopt.scm
index 7b73b58..91a2805 100644
--- a/getopt.scm
+++ b/getopt.scm
@@ -21,7 +21,7 @@
(define getopt:char #\-)
;@
(define getopt:opt #f)
-(define *argv* *argv*)
+;(define *argv* *argv*)
(define *optind* 1)
(define *optarg* 0)
;@
diff --git a/slib.texi b/slib.texi
index 0a5b8f3..6e85a1a 100644
--- a/slib.texi
+++ b/slib.texi
@@ -331,7 +331,7 @@ supported formats for elements of catalog lists:
@item (@var{feature} . @i{<symbol>})
Redirects to the feature named @i{<symbol>}.
@item (@var{feature} . "@i{<path>}")
-Loads file @i{<path>}.
+Loads file @i{<path>}).
@item (@var{feature} source "@i{<path>"})
@cindex source
@code{slib:load}s the Scheme source file @i{<path>}.
@@ -372,6 +372,11 @@ appropriate for the implementation.
@code{macro:load}s the Scheme source file @i{<path>}.
@end table
+@c the following paragraph added by tb (Thomas Bushnell, BSG)
+@noindent
+Note that file names indicated as @i{<path>} may have ``.scm'' or
+another suffix appended to them, depending on the specific Scheme
+system you are using.
@node Catalog Creation, Catalog Vicinities, Library Catalogs, The Library System
@section Catalog Creation