aboutsummaryrefslogtreecommitdiffstats
path: root/scm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'scm.spec')
-rw-r--r--scm.spec80
1 files changed, 38 insertions, 42 deletions
diff --git a/scm.spec b/scm.spec
index 9a1f57c..82b9631 100644
--- a/scm.spec
+++ b/scm.spec
@@ -1,9 +1,9 @@
%define name scm
-%define version 5e5
+%define version 5f2
%define release 1
%define implpath %{prefix}/lib/scm
%define slibpath %{prefix}/lib/slib
-%define dumparch setarch i386
+%define dumparch setarch %{_target_cpu}
# rpm seems to require all on one line, bleah.
%define features cautious bignums arrays inexact dump dynamic-linking macro engineering-notation
@@ -19,8 +19,8 @@ Provides: scm
Requires: slib
Summary: SCM Scheme implementation
-Source: ftp://swiss.csail.mit.edu/pub/scm/scm-%{version}.zip
-URL: http://swiss.csail.mit.edu/~jaffer/SCM
+Source: http://groups.csail.mit.edu/mac/ftpdir/scm/scm-%{version}.zip
+URL: http://people.csail.mit.edu/jaffer/SCM
BuildRoot: %{_tmppath}/%{name}-%{version}
Prefix: /usr
@@ -33,7 +33,7 @@ This distribution requires libdl.so from the glibc-devel package and the
slib Scheme library package. If your machine lacks XFree86 or readline,
install with --nodeps.
-%define __os_install_post /usr/lib/rpm/brp-compress
+# %define __os_install_post /usr/lib/rpm/brp-compress
%prep
rm -rf /var/tmp/%{name}-%{version}
@@ -55,60 +55,55 @@ make clean
export PATH=.:$PATH # to get scmlit in the path.
# Build the executable.
-./build -h system -o udscm5 --compiler-options="-O3" -l debug -s %{implpath} -F %{features}
+./build -h system -o udscm5 --compiler-options="-O2" -l debug -s %{implpath} -F %{features}
echo "(quit)" | ./udscm5 -no-init-file -r5 -o scm
-make check
+# make check
# Build dlls
make x.so
-./build -h system -t dll -F curses --compiler-options="-O3"
-./build -h system -t dll -c differ.c --compiler-options="-O3"
-./build -h system -t dll -c sc2.c --compiler-options="-O3"
-./build -h system -t dll -c rgx.c --compiler-options="-O3"
-./build -h system -t dll -c record.c --compiler-options="-O3"
-./build -h system -t dll -c gsubr.c --compiler-options="-O3"
-./build -h system -t dll -c ioext.c --compiler-options="-O3"
-./build -h system -t dll -c posix.c --compiler-options="-O3"
-./build -h system -t dll -c unix.c --compiler-options="-O3"
-./build -h system -t dll -c socket.c --compiler-options="-O3"
-./build -h system -t dll -c ramap.c --compiler-options="-O3"
-./build -h system -t dll -c byte.c --compiler-options="-O3"
-./build -h system -t dll -F edit-line --compiler-options="-O3"
-./build -h system -t dll -F x --compiler-options="-O3"
+./build -h system -t dll -F curses --compiler-options="-O2"
+./build -h system -t dll -F edit-line --compiler-options="-O2"
+./build -h system -t dll -c differ.c --compiler-options="-O2"
+./build -h system -t dll -c sc2.c --compiler-options="-O2"
+./build -h system -t dll -c rgx.c --compiler-options="-O2"
+./build -h system -t dll -c record.c --compiler-options="-O2"
+./build -h system -t dll -c gsubr.c --compiler-options="-O2"
+./build -h system -t dll -c ioext.c --compiler-options="-O2"
+./build -h system -t dll -c posix.c --compiler-options="-O2"
+./build -h system -t dll -c unix.c --compiler-options="-O2"
+./build -h system -t dll -c socket.c --compiler-options="-O2"
+./build -h system -t dll -c ramap.c --compiler-options="-O2"
+./build -h system -t dll -c byte.c --compiler-options="-O2"
+./build -h system -t dll -F x --compiler-options="-O2"
# Build libscm.a static library
./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib \
- --compiler-options="-O3"
+ --compiler-options="-O2"
%install
mkdir -p ${RPM_BUILD_ROOT}%{prefix}/bin
mkdir -p ${RPM_BUILD_ROOT}%{prefix}/lib/scm
-mkdir -p ${RPM_BUILD_ROOT}%{prefix}/man/man1
-make prefix=${RPM_BUILD_ROOT}%{prefix}/ install
-make prefix=${RPM_BUILD_ROOT}%{prefix}/ installlib
+mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
+make prefix=${RPM_BUILD_ROOT}%{prefix}/ \
+ mandir=${RPM_BUILD_ROOT}%{_mandir}/ \
+ infodir=${RPM_BUILD_ROOT}%{_infodir}/ \
+ install
rm -f ${RPM_BUILD_ROOT}%{prefix}/bin/scm
cp udscm5 ${RPM_BUILD_ROOT}%{prefix}/bin/
-# Assume SLIB is in %{slibpath}, as installed by the slib rpm.
+# Assume SLIB is in %{prefix}/lib/slib, as installed by the slib rpm.
cat > ${RPM_BUILD_ROOT}%{prefix}/lib/scm/require.scm <<EOF
-(set! library-vicinity (lambda () "%{slibpath}/"))
+(set! library-vicinity (lambda () "%{prefix}/lib/slib/"))
EOF
-mkdir -p ${RPM_BUILD_ROOT}%{prefix}/info/
-gzip *.info
-cp *.info.gz ${RPM_BUILD_ROOT}%{prefix}/info/
-
%clean
rm -rf $RPM_BUILD_ROOT
%post
-/sbin/install-info %{prefix}/info/scm.info.gz %{prefix}/info/dir
-/sbin/install-info %{prefix}/info/hobbit.info.gz %{prefix}/info/dir
-/sbin/install-info %{prefix}/info/Xlibscm.info.gz %{prefix}/info/dir
echo "(quit)" | %{dumparch} %{prefix}/bin/udscm5 -no-init-file -r5 -o %{prefix}/bin/scm
ln -s %{prefix}/bin/scm %{prefix}/local/bin/scm
ln -s %{prefix}/lib/scm %{prefix}/local/lib/
-%{prefix}/bin/scm -c "(require 'new-catalog)"
+%{prefix}/bin/scm -br new-catalog
%verifyscript
cp -f %{prefix}/lib/scm/r4rstest.scm /tmp/
@@ -169,15 +164,16 @@ rm -f %{prefix}/bin/scm
%{prefix}/lib/scm/keysymdef.scm
%{prefix}/lib/scm/r4rstest.scm
%{prefix}/lib/scm/byte.so
-# %{prefix}/lib/scm/db.so
-%{prefix}/lib/scm/wbtab.scm
-%{prefix}/lib/scm/rwb-isam.scm
+# %{prefix}/lib/scm/wbscm.so
+# %{prefix}/lib/scm/wbtab.scm
+# %{prefix}/lib/scm/rwb-isam.scm
%{prefix}/lib/scm/COPYING
%{prefix}/lib/scm/COPYING.LESSER
-%{prefix}/info/Xlibscm.info.gz
-%{prefix}/info/hobbit.info.gz
-%{prefix}/info/scm.info.gz
-%{prefix}/man/man1/scm.1.gz
+%{_infodir}/Xlibscm.info.gz
+%{_infodir}/hobbit.info.gz
+%{_infodir}/scm.info.gz
+%{_infodir}/dir
+%{_mandir}/man1/scm.1.gz
%{prefix}/lib/libscm.a
%{prefix}/include/scm.h