summaryrefslogtreecommitdiffstats
path: root/scm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'scm.spec')
-rw-r--r--scm.spec18
1 files changed, 10 insertions, 8 deletions
diff --git a/scm.spec b/scm.spec
index 4be109c..5205315 100644
--- a/scm.spec
+++ b/scm.spec
@@ -1,5 +1,5 @@
%define name scm
-%define version 5d6
+%define version 5d9
%define release 1
%define implpath %{prefix}/lib/scm
# rpm seems to require all on one line, bleah.
@@ -18,7 +18,7 @@ Requires: slib
Summary: SCM Scheme implementation.
Source: ftp://swissnet.ai.mit.edu/pub/scm/scm%{version}.zip
-URL: http://swissnet.ai.mit.edu/~jaffer/SCM.html
+URL: http://swissnet.ai.mit.edu/~jaffer/SCM
BuildRoot: %{_tmppath}/%{name}%{version}
Prefix: /usr
@@ -53,20 +53,21 @@ make clean
export PATH=.:$PATH # to get scmlit in the path.
# Build the executable.
-./build -h system -o udscm5 -l debug -s %{implpath} -F %{features}
+./build -h system -o udscm5 --compiler-options="-O3" -l debug -s %{implpath} -F %{features}
echo "(quit)" | ./udscm5 -no-init-file -r5 -o scm
make check
# Build dlls
make x.so
-./build -h system -F curses -t dll
+./build -h system -F curses -t dll --compiler-options="-O3"
./build -h system -t dll -c sc2.c rgx.c record.c gsubr.c ioext.c posix.c \
- unix.c socket.c ramap.c
-./build -h system -F edit-line -t dll
-./build -h system -F x -t dll
+ unix.c socket.c ramap.c --compiler-options="-O3"
+./build -h system -F edit-line -t dll --compiler-options="-O3"
+./build -h system -F x -t dll --compiler-options="-O3"
# Build libscm.a static library
-./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib
+./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib \
+ --compiler-options="-O3"
%install
mkdir -p ${RPM_BUILD_ROOT}%{prefix}/bin
@@ -143,6 +144,7 @@ rm -f %{prefix}/bin/scm
%{prefix}/lib/scm/hobbit.scm
%{prefix}/lib/scm/scmhob.scm
%{prefix}/lib/scm/scmhob.h
+%{prefix}/lib/scm/patchlvl.h
%{prefix}/lib/scm/build.scm
%{prefix}/lib/scm/build
%{prefix}/lib/scm/Iedline.scm