summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 8 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index c3b6b26..07e44fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,21 +21,20 @@ SCM_OPTIONS = -p linux --compiler-options=-O2 --compiler-options=-g \
-F array-for-each \
-F inexact \
-F record \
- -F compiled-closure \
+ -F compiled-closure \
-F generalized-c-arguments \
-F tick-interrupts \
-F i/o-extensions \
-# -F turtlegr \
-F curses \
-F edit-line \
-F regex \
-F socket \
- -F posix \
+ -F posix \
-F unix \
-F dynamic-linking \
-F dump \
-F heap-can-shrink \
- -F macro
+ -F macro
NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
@@ -44,12 +43,14 @@ NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
# make checklit
build:
+ chmod +x bld.scm
$(checkdir)
+ cp debian/require.scm.debian require.scm
${MAKE} scmlit
- test -e /usr/lib/slib || \
+ test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
- cp debian/require.scm.debian require.scm
- SCHEME_LIBRARY_PATH=/usr/lib/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
+# SCHEME_LIBRARY_PATH=/usr/share/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
+ ./bld.scm ${SCM_OPTIONS} > debian/bld
chmod ug+x debian/bld
debian/bld
-rm -f debian/bld