summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index c2f69c5..db0864b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -80,13 +80,15 @@ defines = @DEFS@ \
# rgx.c init_rgx\(\) regcomp, regexec (POSIX)
# crs.c init_curses\(\) lendwin\(\) ... lots ...
-INITS = -DINITS=init_sc2\(\)\;
+#INITS = -DINITS=init_sc2\(\)\;init_rgx\(\)\;init_crs\(\)\;init_edline\(\)\;
+INITS = -DINITS=init_sc2\(\)\;init_rgx\(\)\;
+#FINALS = -DFINALS=lendwin\(\)\;
FINALS = -DFINALS=\;
# If you are using rgx.c, set the next line to point to the include
# directory where your POSIX regexp include files live (if you are using
# GNU regex).
-# RGXFLAGS = -I/archive/regex-0.11/
+RGXFLAGS = -I/usr/include/regex
# If your system needs extra libraries loaded in, define them here.
# -lm For floating point math (needed).
@@ -94,7 +96,8 @@ FINALS = -DFINALS=\;
# -lncurses For curses on Linux (curses has bugs).
# -lterm{cap,lib} May be required for curses support.
# -lregex For POSIX regexp support (rgx.c).
-LOADLIBES = @LIBS@ -lm
+#LOADLIBES = @LIBS@ -lm -lregex -lncurses -lreadline
+LOADLIBES = @LIBS@ -lm -lregex
# Any extra object files your system needs.
extras = @LIBOBJS@
@@ -147,7 +150,7 @@ nunix = $(srcdir)
# examples = examples
examples = $(srcdir)
ffiles = continue.o time.o repl.o fscl.o sys.o feval.o subr.o sc2.o \
-funif.o rope.o ramap.o findexec.o #rgx.o
+funif.o rope.o ramap.o findexec.o rgx.o #edline.o crs.o
fifiles = continue.o time.o repl.o iscm.o fscl.o sys.o feval.o subr.o \
sc2.o funif.o rope.o ramap.o findexec.o #rgx.o
efiles = time.o repl.o escl.o sys.o eeval.o subr.o sc2.o eunif.o #rgx.o
@@ -276,6 +279,8 @@ rgx.o: $(srcdir)/rgx.c $(srcdir)/scm.h Makefile scmconfig.h
$(CC) $(CFLAGS) $(defines) $(RGXFLAGS) -c rgx.c
crs.o: $(srcdir)/crs.c $(srcdir)/scm.h scmconfig.h
$(CC) $(CFLAGS) $(defines) -c crs.c
+edline.o: $(srcdir)/edline.c $(srcdir)/scm.h scmconfig.h
+ $(CC) $(CFLAGS) $(defines) -c edline.c
findexec.o: $(srcdir)/findexec.c
$(CC) $(CFLAGS) $(defines) -c $(srcdir)/findexec.c