aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog154
1 files changed, 154 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 5a69843..1555342 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,157 @@
+2008-02-01 Aubrey Jaffer <jaffer@aubrey.jaffer>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5e4 to 5e5.
+
+2008-01-31 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build (make-readme): Put - between scm and version.
+
+ * keysymdef.scm, x11.scm: X Window System Version 7.1.1
+ Release Date: 12 May 2006
+ X Protocol Version 11, Revision 0, Release 7.1.1
+
+ * Makefile, scm.spec: Always put - between scm and version.
+
+ * unexelf.c, unexmacosx.c, unexsgi.c, unexsunos4.c, gmalloc.c,
+ lastfile.c, macos-config.h, r4rstest.scm, syntest2.scm,
+ unexalpha.c, unexec.c, !#.c, build, build.scm, ecrt0.c,
+ findexec.c, bench.scm:
+ Changed license to GPL version 3.
+
+ * Transcen.scm, Tscript.scm, unif.c, unix.c, x.c, xgen.scm,
+ subr.c, sys.c, time.c, scm.texi, script.c, setjump.h, socket.c,
+ split.scm, scm.c, scm.h, scmfig.h, scmhob.h, scmhob.scm,
+ scmmain.c, repl.c, rgx.c, rope.c, sc2.c, scl.c, Macro.scm,
+ Makefile, mkimpcat.scm, pi.c, pi.scm, posix.c, ramap.c,
+ record.c, Iedline.scm, Init5e4.scm, Link.scm, Macexp.scm,
+ inc2scm, ioext.c, Idiffer.scm, gsubr.c, hobbit.scm, .gdbinit,
+ differ.c, disarm.scm, dynl.c, edline.c, eval.c,
+ get-contoffset-ia64.c, byte.c, bytenumb.c, compile.scm,
+ continue-ia64.S, continue.c, continue.h, crs.c, debug.c:
+ Changed license to LGPL version 3.
+
+2008-01-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Tscript.scm: Handle EOF.
+
+2008-01-28 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Overview): SCM is a GNU package.
+ (GNU Free Documentation License): Subsection of "Copying".
+
+ * Makefile, build.scm (manifest): Added fdl.texi and
+ COPYING.LESSER.
+
+ * README, build (make-readme): SCM is a GNU package.
+
+2008-01-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * byte.c (init_byte): Identity isn't defined yet; use cr.
+
+2008-01-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi: Changed to "GNU Free Documentation License".
+
+ * fdl.texi (GNU Free Documentation License): Added.
+
+ * COPYING.LESSER: Added "GNU LESSER GENERAL PUBLIC LICENSE".
+
+ * COPYING: "GNU GENERAL PUBLIC LICENSE" Version 3.
+
+ * byte.c (bytes-append, bytes->string, string->bytes): Added.
+
+2008-01-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.nsi (Uninstall): Delete tmp1, tmp2, and tmp3.
+
+2008-01-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * macos-config.h, unexmacosx.c, lastfile.c:
+ Added from Emacs for MacOS (darwin).
+
+ * build.scm (C-libraries): Added dump and dlll darwin entries.
+ (make-dll-archive, compile-dll-c-files): Added Darwin tagets.
+ (manifest): Added entries for "macos-config.h" and "lastfile.c".
+
+ * Makefile (all): Make x.so only if /usr/X11R6/lib exists.
+ (install, installlib): test -d is not needed with mkdir -p.
+
+2008-01-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (install): mkdir -p.
+
+2008-01-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (RSYNC): --rsync-path no longer needed.
+
+2008-01-15 Radey Shouman <shouman@comcast.net>
+
+ * repl.c: Fix igc prototype, avert warning.
+
+2008-01-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.nsi: Create shortcuts at installation; removed SCM.lnk.
+ (MUI_ICON): Set to "SCM.ico".
+
+ * Makefile ($(DOSCM)scm$(VERSION).zip): Removed SCM.lnk.
+
+2008-01-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.nsi: Delete scmlit.exe, implcat, and slibcat when
+ uninstalling.
+
+2008-01-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile ($(htmldir)Xlibscm_toc.html)
+ ($(htmldir)hobbit_toc.html): Add SCM.ico.
+
+2008-01-09 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (all): Make differ.so.
+ (libscm.a, db.so, bytenumb.so, differ.so, myturtle, x.so): Depend
+ on scm.h and scmfig.h.
+ (doszip): Added SCM.ico
+
+ * scm.h, repl.c: Made ints_disabled VOLATILE.
+
+2008-01-09 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (ceval_1): Remove redundant DEFER_INTS_EGC from
+ new code.
+
+2008-01-07 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (scm_eval_values, ceval_1): Catch VALUES arity errors
+ in top-level repl evaluations. Eg (list (values 1 2)) now
+ throws an error even when typed to repl.
+
+ * scm.h (IM_EVAL_VALUES): Add isym for use by scm_eval_values.
+
+ * repl.c (isymnames): Add name for IM_EVAL_VALUES.
+
+2008-01-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ANNOUNCE: Culled and reorganized URLs.
+
+2007-12-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ioext.c (directory-for-each): Require 'filename, not 'glob.
+
+ * Init5e4.scm (slib:features): Added srfi-96.
+
+2007-12-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (CITERS): Added $(htmldir)FreeSnell/index.html.
+
+2007-12-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.c (init_scm): The streams when the program was dumped need
+ to be reset at initialization.
+
+2007-12-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SCM Features): Hobbit is included in distribution.
+
2007-11-28 Aubrey Jaffer <agj@alum.mit.edu>
* bytenumb.c (scm_integer_to_bytes): Declaration must start block.