summaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog551
1 files changed, 550 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 6b10d92..0e564f2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,553 @@
+2003-11-30 Aubrey Jaffer <jaffer@scm.jaffer>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5d8 to 5d9.
+
+2003-11-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Embedding SCM): Updated libtest example for
+ init_user_scm indirection (which Radey added 2003-01-24).
+
+2003-11-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (MS-DOS Compatible Scripts): Added sharpbang URL.
+
+2003-11-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ramap.c (array-map): Added.
+
+2003-10-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (inexact->exact): Added tests.
+ (exact->inexact): check for both exact and inexact argument.
+
+2003-10-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (build): processor-family now symbol; i8086 <- 8086.
+
+ * mkimpcat.scm: Added rwb-isam feature.
+
+2003-10-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (dfiles): Added version.txi platform.txi features.txi.
+
+2003-10-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (manifest): Added "byte.c".
+
+ * byte.c: Added. Improves RANDOM speed by 32%.
+
+2003-10-15 <agj@alum.mit.edu>
+
+ * scm.texi (Build Options): Described *.opt option files.
+
+ * Makefile (CFLAGS): Removed "-g".
+
+ * bench.scm (benchmark-prng): Limit to 1000 samples if no bignums.
+
+ * Makefile (pg.opt, gdb.opt, dlls.opt): Added. Cleanup options.
+
+2003-10-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (compile-c-files): Removed "-O" and "-Wall" options;
+ use --compiler-options= instead.
+
+ * subr.c (scm_logbitp, scm_ash): Prevent wraparound (1>>32==1).
+
+2003-09-25 Sam Hocevar
+
+ * r4rstest.scm (test-inexact): SECTION 6.2 checks that
+ (not (eqv? 1 1.0)).
+
+2003-09-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * bench.scm (prng): Calls to random:random --> random.
+
+2003-09-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scmfig.h (CDR_DOUBLES, SHORT_INT): Added __ia64 #defines.
+
+ * scm.texi (Automatic C Preprocessor Definitions): Added IA64.
+
+2003-09-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ioext.c, posix.c (system->line): Defined.
+
+2003-09-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (continue.o): Was missing scmfig.h and scm.h
+ dependencies.
+
+2003-08-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm: Use open-table! and open-table.
+
+ * build (print-manifest, make-features-txi): Use open-table.
+
+2003-08-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (6 5 5): Added some kawa chokers: #i, #e.
+ Added more kawa STRING->NUMBER bait.
+
+2003-08-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Line Numbers): Added read-for-load.
+ (Load Syntax): Distinguished from Read syntax; documented #?line,
+ #?column, and #?file.
+ (Data Type Representations): Updated port formats.
+
+ * Init5d8.scm (slib:eval-load): Use *load-reader*.
+
+ * repl.c (scm_read_for_load): Added.
+ (p_read_numbered, p_read_for_load, p_read): Added locatives.
+ (lreadr): Pass appropriate read routine to load:sharp; read:sharp.
+ (flgs): Renamed from nump to reduce interference with INUMP, etc.
+
+2003-08-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d8.scm (load:sharp, read:sharp): Split read:sharp.
+ (load:sharp, read:sharp, char:sharp, read:array): Added READ arg.
+ (char:sharp): Renamed from read:sharp-char.
+ (read:sharp): Integrated #; into.
+
+ * repl.c (scm_read): Renamed from lread().
+ (loc_charsharp): Renamed from loc_readsharpc.
+ (loc_loadsharp): Added to separate LOAD-macros from READ-macros.
+ (f_read_numbered): Removed unused variable.
+ (repl, tryload, scm_load_string): Use scm_read_numbered().
+ (lreadpr): Dispatch to loc_readsharp or loc_loadsharp depending on
+ nump.
+
+2003-08-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (floequal): Fixed so 0/0==0/0.
+ (eqv, eqp): Use floequal.
+
+2003-08-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (init_eval): add_feature("primitive-hygiene").
+
+ * mkimpcat.scm (primitive-hygiene): Use feature to conditionalize
+ macro association.
+
+2003-08-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (eqp): Fixed so (let ((nan 0/0)) (= nan nan)) ==> #t.
+ (in2ex): Infinite loop on (inexact->exact 0/0) change to err.
+
+2003-07-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (uninstallinfo): Created.
+ (uninstall): Remove libscmdir files.
+
+2003-07-22 Andy Gaynor <silver@silver.reedkin.org>
+
+ * Makefile (Xlibscm.info, hobbit.info): Fixed / separators.
+
+ * unif.c (make_sh_array): Bracket with ifndef RECKLESS.
+
+2003-07-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (release): Make pdf(s).
+
+2003-07-11 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (m_case): Check on clauses for CASE was
+ confused by line-number annotations.
+
+2003-07-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * hobbit.texi (SLIB Logical Procedures): Removed "logical:"
+ aliases.
+
+ * compile.scm, hobbit.scm: Added REQUIRE-IFs.
+
+ * build, build.scm: Moved requires to top.
+
+2003-07-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d8.scm (make-array): Alias of create-array.
+ (read:sharp): Feature evaluation now slib:provided?
+
+2003-06-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (test-string->number): Implementations which don't
+ allow division by 0 can have fragile string->number.
+
+2003-06-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (iflo2str): Use negated conditional to handle 0/0.
+ (NaN2str): Removed "#i" prefix.
+
+2003-06-22 Aubrey Jaffer <jaffer@aubrey.jaffer>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5d7 to 5d8.
+
+ * hobbit.texi (Macro-Expansion and Analysis): Put @code{} around
+ some confusing words (or or and).
+
+2003-06-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Array Mapping): Moved after uniform arrays.
+
+ * Init5d7.scm (make-array): Removed legacy procedure.
+
+ * x.c (x_free_color_cells, x_screen_size): Corrected prot numbers.
+
+ * eval.c (scm_profile): Corrected prot numbers.
+
+ * record.c (MAKE_REC_INDS): Corrected prot number.
+
+ * ramap.c (ramapc, array_imap): Corrected prot codes.
+ (array-fill!) Removed.
+
+ * unif.c (uniform-vector-fill!): Removed.
+
+2003-06-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Macro.scm (@pprint, @print): display --> write.
+
+2003-06-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (istr2flo): 1/0, -1/0, 0/0 are inexact infinities.
+ (idbl2str): Infinities represented by #i+1/0, #i-1/0, #i0/0.
+
+ * x11.scm: Lots of symbol ID-codes changed in XFree86-4.2.0.
+
+ * keysymdef.scm: Lots of new symbols in XFree86-4.2.0.
+
+2003-04-04 Radey Shouman <radey@attbi.com>
+
+ * sys.c (prinport): print column and line numbers if available.
+
+2003-03-12 Radey Shouman <radey@attbi.com>
+
+ * Init5d7.scm (read:sharp-char): Add #\x<hex-number>
+ #\o<octal-number>, #\d<decimal-number> character read syntax.
+
+ * repl.c (lreadr): Remove #\<octal-number> syntax,
+ moved to read:sharp-char.
+
+2003-03-12 Radey Shouman <shouman@attbi.com>
+
+ * rope.c (init_rope): Replace static initializer for scm_protidx
+ with initialization in init_rope so that RESTART works.
+
+ * sys.c (init_storage):
+ * eval.c (init_eval): Replace static initializers so that
+ RESTART works.
+
+2003-03-11 Radey Shouman <shouman@attbi.com>
+
+ * sys.c (close_port): Return value from port close function so
+ we can get the exit status of pipes at close time.
+ (free_storage): Re-initialize some values for RESTART.
+
+2003-03-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (for_each): Fixed arity_check message.
+
+2003-02-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (compile-dll-c-files, make-dll-archive, make-archive):
+ Added for gnu-win32.
+
+2003-02-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (make-archive, make-dll-archive, compile-dll-c-files):
+ Added for microsoft-c-nt.
+
+2003-01-29 Radey Shouman <shouman@attbi.com>
+
+ * repl.c (final_repl): Make sure to reinitialize closure print
+ information strings when restarting -- this caused segfaults under
+ windows.
+
+2003-01-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c, sys.c (s_redefining): Definition moved to "sys.c" from
+ "eval.c".
+
+2003-01-24 Radey Shouman <shouman@attbi.com>
+
+ * dynl.c (prinshl, scm_dyn_link, scm_dyn_unlink, scm_dyn_call,
+ scm_dyn_main_call, init_dynl):
+ * scm.c (scm_init_extensions):
+ * scm.h (SCM_EXPORT):
+ * scmmain.c (main):
+
+ Changes to allow dynamic linking under MS win32.c
+
+2003-01-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (ceval_1): Added workaround for GCC-2.3.1 on SPARC bug
+ reported by Steve VanDevender.
+
+2003-01-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * bench.scm (benchmark-prng): Increased time threshold.
+
+ * eval.c (ceval_1): arg1 now #defined to (struct) t.arg_1.
+ Consistently nets 3% on pi benchmark.
+
+ * bench.scm (benchmark-pi): Moved threshold; 450.MHz Pentium II
+ was on edge.
+
+2003-01-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (ceval_1): "SCM arg1" replaces unused "union {} t".
+
+2003-01-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * hobbit.texi (Index): Added.
+ (Compiling And Linking): Documented option-files.
+
+ * compile.scm (compile-file, compile->executable): Use
+ option-files named for the first argument with ".opt" appended.
+
+ * build.scm (options-file): Made nary parameter.
+ (build:build): Report option-files used.
+
+ * build (build-from-argv): Don't splice out "-f <options-file>".
+
+2003-01-02 Steve VanDevender <stevev@hexadecimal.uoregon.edu>
+
+ * build.scm (compile-c-files, compile-dll-c-files)
+ (make-dll-archive): Added for OSF1 (was ALPHA).
+
+ * socket.c (inet:make-address): Removed duplicate definition.
+
+2002-12-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.h: Removed unused prototypes.
+
+ * scl.c (difference, divide):
+ * sys.c (init_storage, egc_copy_stack):
+ * unif.c (dims2ura, bit_position):
+ * repl.c (everr): Added {} to squelch gcc -Wall.
+
+ * ramap.c (sc2array): Moved prototype from "scm.h".
+
+2002-12-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d7.scm (logical:ones): Return 0 for 0 argument.
+ (gray-code->integer): Improved running time from O(b^2) to
+ O(b*log(b)).
+
+2002-12-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SCM Options): Clarified descriptions of -, --, and -s.
+
+2002-12-19 Radey Shouman <shouman@attbi.com>
+
+ * Init5d7.scm (error): Terminate in breakpointing error function
+ even if REQUIRE fails (and calls ERROR).
+
+2002-12-18 Radey Shouman <shouman@attbi.com>
+
+ * ioext.c (l_opendir, l_readdir, l_closedir, l_rewinddir):
+ Added for win32 (tested on XP).
+
+2002-12-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (scmlit): #define CAUTIOUS.
+
+ * sys.c (make_subr): Reuse repeated names.
+
+ * eval.c (checked_define): Share warning strings.
+
+ * time.c (your_time): Shortened long warning message.
+
+ * rope.c (scm_gc_protect): Check if argument is already protected.
+
+ * scm.texi (Changing Scm): Added scm_protect_temp() and
+ scm_gc_protect().
+ (Type Conversions): Added num2short(), num2dbl(), and
+ scm_base_addr().
+
+2002-12-09 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (array-for-each, record, generalized-c-arguments)
+ (curses, regex, socket, posix, unix): Changed to compiled-inits.
+
+ * Makefile (udscm4.opt, udscm5.opt, libscm.opt): Added.
+ (udscm4, udscm5, libscm.a): Take feature options from .opt file.
+ The *.opt files are never overwritten.
+
+ * posix.c (scm_getlogin): Removed.
+
+ * scm.texi (SCM Session): getlogin moved from Posix Extensions.
+
+ * Init5d7.scm (getlogin): Posix getlogin is useless; always define
+ getlogin using getenv.
+
+2002-12-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build (build-from-argv): Fluid-let getopt-- to splice in options
+ from -f <filename>.
+
+ * build.scm (build): Added -f <filename> option.
+
+ * Makefile (bench): Run both pi and prng benchmarks.
+
+ * bench.scm (time-call): Abstracted timing procedure.
+ (benchmark-prng): Added.
+
+2002-12-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d7.scm:
+ * build (build-from-argv): Global variable *argv* replaces argc,
+ argv arguments.
+ (build-from-whole-argv, bi): Straightened.
+
+2002-11-26 Aubrey Jaffer <jaffer@aubrey.jaffer>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5d6 to 5d7.
+
+2002-11-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d6.scm (error, warn): Simplified.
+
+2002-11-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.c (init_buf0): ifndef scoping didn't match "{}"s.
+
+ * x.c, unix.c, unif.c, sys.c, subr.c, socket.c, scm.texi, scm.h,
+ scm.c, scl.c, sc2.c, rope.c, rgx.c, repl.c, record.c, ramap.c,
+ posix.c, ioext.c, gsubr.c, eval.c, edline.c, dynl.c, debug.c,
+ crs.c (ASRTER): Renamed from ASSERT; conflict with "windows.h".
+
+ * scm.texi (Compiling and Linking Custom Files): ./build.
+
+2002-11-25 dai <inukai.d@jeans.ocn.ne.jp>
+
+ * build.scm (compile-c-files freebsd, compile-dll-c-files
+ freebsd): Fixed for FreeBSD.
+
+ * build: Added -no-init-file to first line.
+
+2002-11-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d6.scm (browse-url): Added.
+
+2002-11-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (I/O-Extensions): directory feature renamed from
+ directory-for-each.
+
+ * ioext.c (current-directory, make-directory): Added.
+
+2002-11-15 Radey Shouman <shouman@attbi.com>
+
+ * sys.c (scm_dynthrow): Fix bug in throwing to continuation
+ when environment stack segment needed to grow.
+ (scm_estk_shrink): Make sure the entire chain of non-writable
+ environment stack segments is appropriately marked.
+ Thanks to <david@anvil.com> for calling attention to the problem.
+
+2002-11-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d6.scm (logical:rotate): Added.
+
+2002-10-30 Radey Shouman <shouman@attbi.com>
+
+ * eval.c (m_body): Fixed error reporting -- was segfaulting.
+
+2002-10-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * unif.c (make_sh_array): scm_arity_check(mapfunc).
+
+2002-08-20 Radey Shouman <shouman@attbi.com>
+
+ * eval.c (m_do): Splicing BEGIN in the test of a DO removed because
+ it is buggy. Thanks for bug report from Daniel Skarda <0rfelyus@ucw.cz>.
+
+2002-07-14 Rainer Urian <rainer.urian@symbolictool.de>
+
+ * sys.c: include <io.h> ifdef POCKETCONSOLE.
+
+ * scmmain.c (scm_find_implpath): Don't scm_try_path ifdef
+ POCKETCONSOLE.
+
+ * scmfig.h (NOSETBUF): Set ifdef POCKETCONSOLE.
+
+ * scm.texi (Automatic C Preprocessor Definitions): Added
+ _WIN32_WCE, _M_ARM, _M_ARMT.
+
+ * scm.h (CODE):
+ * eval.c (I_SYM, I_VAL):
+ * repl.c (iprin1): Workaround Microsoft CLARM compiler bug.
+
+2002-06-07 Rainer Urian <rainer.urian@symbolictool.de>
+
+ * scm.c (scmable_signal):
+ * repl.c (wait_for_input):
+ * scmmain.c (main):
+ * scmfig.h:
+ Fixed console break handling for win32 systems, tested using
+ Microsoft visual C and the MinGW gcc port.
+
+2002-06-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Syntax): Added example of SLIB/repl use.
+ (The Language): Reorganization of most sections.
+
+ * hobbit.texi: Fixed stale email address.
+
+2002-06-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Unix Scheme Scripts, Unix Shell Scripts): Updated
+ script mechanics.
+ (Files and Ports): Moved port-filename, port-line, and port-column
+ from "Miscellaneous Procedures".
+
+2002-05-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * inc2scm (inc2scm): Replaces go-script; takes args.
+
+ * xgen.scm (xgen.scm): Replaces go-script; takes args.
+
+ * compile.scm (compile.scm): Replaces go-script; takes args.
+
+2002-05-25 David S. <davids@idiom.com>
+
+ * scmmain.c, scm.c, time.c, repl.c, ioext.c, sys.c, crs.c,
+ posix.c, socket.c, unix.c, findexec.c: __NetBSD__ support.
+
+ * scm.texi (Automatic C Preprocessor Definitions): Add __NetBSD__
+
+2002-05-21 Radey Shouman <shouman@attbi.com>
+
+ * unif.c (shap2ra): Check that upper bound is >= lower bound.
+
+2002-05-18 Radey Shouman <shouman@attbi.com>
+
+ * unif.c (dim2ura): Fix unsigned vs signed comparison problem that
+ caused negative sizes to be passed to make_uve.
+
+2002-04-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SLIB): Load of "require" unneeded.
+
+ * requires.scm (library-vicinity): Removed call of LOAD.
+
+ * Init5d6.scm (set-vicinities!): Fluid-let of LOAD unneeded.
+ (program-vicinity, pathname->vicinity): Removed to slib.
+
+2002-04-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Unix Extensions, Posix Extensions): Added @cindexs.
+
+ * scl.c (dbl_mant_dig): Always use variable dbl_mant_dig when
+ ifdef FLOATS.
+
+2002-04-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * script.c (dld_find_executable): Eliminated unused #defines.
+
+2002-04-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile, scm.spec (install): Added patchlvl.h.
+
2002-04-14 Aubrey Jaffer <jaffer@aubrey.jaffer>
* patchlvl.h (SCMVERSION): Bumped from 5d5 to 5d6.
@@ -6981,4 +7531,3 @@ Mon Jan 28 12:45:55 1991 Aubrey Jaffer (jaffer at foxkid)
* scm.c (err_head, wta): added fflush calls to error routines so
that error message come out in proper order.
-