summaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog329
1 files changed, 327 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 0e564f2..df2ebd4 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,328 @@
+2005-06-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.spec (slibpath, dumparch): Added.
+
+2005-06-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (DOSCM): Abstracted DOS zip creation.
+
+ * Transcen.scm, Init5e1.scm (infinite?, finite?): Added.
+
+ * scl.c (makdbl, init_scl): Don't bother with scm_narn for MSC.
+ (scm_finitep): Removed to Transcen.scm and Init5e1.scm.
+
+ * scm.h (scm_narn): Renamed from infi.
+
+2005-06-21 Aubrey Jaffer <jaffer@aubrey>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5d9 to 5e1.
+
+2005-06-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (limit): Check and report input errors.
+
+2005-06-12 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (limit): Added srfi-70 procedure.
+
+2005-05-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm: Removed tests for 0^0 in anticipation of SRFI-70.
+
+ * scl.c (scm_complex_p): 0/0 is not complex.
+
+2005-05-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makfile (scm5): Added target for undumpable architectures (FC3).
+ * Transcen.scm (expt, quotient, remainder, modulo): SRFI-70
+ extensions.
+
+2005-05-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (inf2str): Renamed from NaN2str().
+ (makdbl): Returns `infi' for unreal infinities.
+ (scm_rationalp): Added (infinities not).
+
+ * scm.h (infi): Nonreal infinity added to sys_protects.
+
+ * scmfig.h (IS_INF): Removed.
+
+ * Init5d9.scm (numerator, denominator): Check rational.
+
+2005-04-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (numerator, denominator): Added.
+
+2005-04-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (with-load-pathname): Moved from slib/require.scm.
+
+2005-03-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (install): Added db.so.
+ (uninstall): Beefed up.
+
+2005-01-30 Radey Shouman <shouman@comcast.net>
+
+ * Init5d9.scm (read:array): Make default rank one, not zero.
+ (as before).
+
+2005-01-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (any-bits-set?, first-set-bit, bitwise-merge): Added
+ remaining SRFI-33 aliases.
+
+2005-01-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (read-array-type): Handle A:char.
+
+2005-01-19 Radey Shouman <shouman@comcast.net>
+
+ * script.c (find_impl_file): Find executable path accurately
+ on MS windows.
+
+ * Init5d9.scm (read:array): (read:sharp): (load:sharp): Use read
+ argument passed to READ:SHARP only for eval, otherwise unexpected
+ line numbers cause trouble. eg #+(or) in load file.
+
+2005-01-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (MS-DOS Compatible Scripts): Replaced %0 ... %9 with
+ %~f0 %*
+
+ * xgen.scm, build.bat, inc2scm: Replaced %0 ... %9 with %~f0 %*
+
+2005-01-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (list->array, vector->array, array->vector): Added.
+
+2005-01-09 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm: Updated per SRFI-60.
+
+ * subr.c (scm_copybitfield): Changed argument order (SRFI-60).
+
+2005-01-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (arithmetic-shift): Aliases ASH.
+
+ * scmhob.scm: Moved LOGICAL: aliases from logical.scm.
+
+2005-01-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (read:array, read:sharp): Accept whole boatload of
+ SRFI-58 sytnaxes.
+
+2005-01-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * unif.c (scm_prot2type): Was not defaulting correctly.
+
+2004-12-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * unif.c (raprin1): Don't elide 1 from #1A.
+
+2004-11-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (SETARCH): Workaround for unexec on Fedora Linux i386.
+
+2004-11-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (test-numeric-predicates): Raised exponent so
+ intransitive 128-bit-float implementations are caught.
+
+2004-10-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * byte.c (scm_write_byte): Was hosed for even number of bytes.
+
+ * scl.c (scm_intexpt): EXPT of zero behaves like Common-Lisp.
+
+ * r4rstest.scm (SECTION 6 5 5): Removed tests for (EXPT 0 -255)
+ so Common-Lisp compatible EXPT won't bomb.
+ Test EXPT inexactness contagion of zero cases.
+
+ * Transcen.scm (expt): Changed so (expt 0 -5) signals error.
+ EXPT of zero returns zero or one matching input exactness.
+
+2004-10-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (SECTION 6 5 5): Added exact tests for EXPT.
+ Inexact EXPT corner cases should return inexacts.
+
+ * scl.c (scm_intexpt): Bombed given (integer-expt 0 25).
+
+2004-09-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (inexact->exact, exact->inexact): Identity when
+ exacts-only.
+
+2004-09-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ramap.c (array:copy!): Renamed from array-copy!.
+ (array_copy): Arguments reversed.
+
+2004-09-12 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SCMDB): Added section with link.
+ (Hobbit): Moved notinfo stuff after Xlib so it appears same place
+ in all products.
+
+2004-09-09 Wim Lewis
+
+ * Makefile (scmflags): Use "cmp -s" instead of "diff".
+ (x.h): Use -x $CPROTO to test for cproto's existence.
+
+2004-09-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (dlll gnu-win32): Changed flag to "-DSCM_WIN_DLL".
+ (dlll microsoft-c-nt): Changed flag to "-DSCM_WIN_DLL".
+
+ * scm.h (SCM_WIN_DLL): renamed from SCM_DLL and DLLSCM.
+ Unatabified.
+
+ * ramap.c (init_ramap): Its tc7_subr_2 not tc7_subr2!
+
+2004-08-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * byte.c (scm_substring_read): Fixed off-by-one reading backwards.
+
+2004-07-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (db.so, rwb-isam.scm, wbtab.scm): Added.
+
+2004-07-28 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (wb): Added for source in ../wb/.
+ (build:command): Assume c-files are relative to cd; don't prefix
+ c-files with scm-srcdir.
+ (compile-dll-c-files): Many were missing include-spec "-I" call.
+
+ * mkimpcat.scm: Support WB compiled in implementation-vicinity.
+
+2002-07-07 Radey Shouman <shouman@attbi.com>
+
+ * scm.texi (Debugging Continuations): Added documenting
+ frame-trace, frame->environment, scope-trace, frame-eval.
+
+2004-06-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (slib:eval-load): Define moved to "slib/require.scm"
+
+2004-06-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (err_head): Fixed "loaded from" messages and formatting.
+
+ * Init5d9.scm (slib:eval-load): Converted to use (SLIB)
+ with-load-pathname.
+
+ * Link.scm (link:link): Converted to use with-load-pathname.
+
+2004-05-28 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile: (SHOBJS): Abstracted *.sl and *.so.
+
+2004-05-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (iprin1): Slashify uppercase chars in symbols.
+
+2004-04-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * differ.c, Idiffer.scm: Linear-space O(PN) sequence comparison.
+
+ * scm.spec (differ.so, Idiffer.scm): Added to %files.
+
+ * Makefile (differ.so): Added target.
+
+ * scm.texi (Sequence Comparison): Added.
+
+2004-03-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ramap.c (rafe): Removed unused variables inc and base.
+
+2004-03-26 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (toplevel_define) (scm_arity_check) (ceval_1)
+ (scm_cvapply) (apply): Pass multiple arguments to captured
+ continuations, eg:
+ (call-with-values (lambda () (call/cc (lambda (k) 1 2))) list)
+ Better error checking for multiple-value returns in repl.
+
+ * sys.c (scm_dynthrow): Allow passing multiple arguments
+ to a continuation captured in the producer argument of
+ call-with-values.
+
+2004-03-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (mydlls): Call BUILD separately for each dll.
+
+2004-03-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * mkimpcat.scm: Added 'DIFF.
+
+ * build.scm (compile-dll-c-files): For those platforms supporting
+ shared object files, generate just one combining all FILES.
+
+2004-02-24 Radey Shouman <shouman@comcast.net>
+
+ * subr.c (scm_logbitp): Fixed bug in range check for fixnum
+ case. Eg (logbit? 10 #xffff) now correctly returns #t.
+
+2004-02-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5d9.scm (read:array): Ignore third argument; line-numbers
+ were hosing array reading.
+
+2004-02-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (handle_it): Added comments. Call scm_fill_freelist() if
+ interrupt lacks handler.
+
+2004-02-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (scm_top_level): Default value of toplvl_fun just once.
+
+2004-01-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (compile-dll-c-files): Fixed -I for netbsd, openbsd.
+ (compile-dll-c-files): Added -I for svr4-gcc-sun-ld.
+ (file-categories): Renamed CORE from REQUIRED.
+
+2004-01-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (read_token, iprin1, lreadr): Handle slashified symbols.
+
+2004-01-19 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (macroexp1): Catch more syntax errors: ('f . f)
+
+2004-01-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SIOD copyright): Put in subsection.
+ (The SCM License): Parallel Guile License text.
+
+2004-01-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Automatic C Preprocessor Definitions): Added "sun".
+
+ * unif.c, sys.c: Sun cc doesn't like fwrite declaration.
+
+2004-01-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (srcdir.mk): Include after target.
+ Separated shell assignments and exports.
+
+2004-01-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm: Added URLs.
+
+2004-01-07 Radey Shouman <shouman@comcast.net>
+
+ * eval.c (m_case) (definedp): Avoid segfault in cases of syntax
+ error.
+
+2003-12-03 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (definedp): Added third (dummy) argument.
+
2003-11-30 Aubrey Jaffer <jaffer@scm.jaffer>
* patchlvl.h (SCMVERSION): Bumped from 5d8 to 5d9.
@@ -3431,8 +3756,8 @@ Fri Sep 11 17:25:14 EDT 1998 Aubrey Jaffer <jaffer@scm.colorage.net>
1998-08-10 Aubrey Jaffer <jaffer@colorage.com>
- * sys.c (scm_fill_freelist): added. Assures that at least
- MIN_GC_YIELD cells are in freelis. This is used before returning
+ * sys.c (scm_fill_freelist): Added; assures that at least
+ MIN_GC_YIELD cells are in freelist. This is used before returning
from interrupts.
* repl.c (handle_it): Discard 2 cells (because of CDR in NEWCELL).