summaryrefslogtreecommitdiffstats
path: root/x.h
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2003-05-07 08:36:40 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commite21d47d7813159bb71e0671df9b52ec0470c358d (patch)
tree3c7770ea846123c291f599044e9f234ac17616bb /x.h
parent8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff)
parentdeda2c0fd8689349fea2a900199a76ff7ecb319e (diff)
downloadscm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz
scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low * Fix hppa compile. Closes: #144062 scm (5d6-3.1) unstable; urgency=low * NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171 scm (5d6-3) unstable; urgency=low * Add build depend on xlibs-dev (Closes: #148020) scm (5d6-2) unstable; urgency=low * Remove libregexx-dev from build-depends. * Change build to use ./scmlit rather than scmlit (should fix some build problems) (looks like alpha is mostly building) * New release (Closes: #140175) * Built with turtlegraphics last time (Closes: #58515) scm (5d6-1) unstable; urgency=low * New upstream. * Add xlib and turtlegr to requested list of features. (closes some bug) * Make clean actually clean most everything up. * Remove hacks renaming build to something else and just set build as a .PHONY target in debian/rules. * Add the turtlegr code. scm (5d5-1) unstable; urgency=low * New upstream * Has fixes for 64 bit archs. May fix alpha compile problem. Does fix (Closes: #140175) * Take out -O2 arg. scm (5d4-3) unstable; urgency=low * Don't link with regexx, but just use libc6's regular expression functions. * Define (terms) to output /usr/share/common-licenses/GPL (Closes: #119321) scm (5d4-2) unstable; urgency=low * Add texinfo to build depends (Closes: #107011) scm (5d4-1) unstable; urgency=low * New upstream release. * Move install-info --remove to prerm. scm (5d3-5) unstable; urgency=low * Move scm info files to section "The Algorithmic Language Scheme" to match up with guile. scm (5d3-4) unstable; urgency=low * Fix build depends (Closes: #76691) scm (5d3-3) unstable; urgency=low * Fix path in scm dhelp file. scm (5d3-2) unstable; urgency=low * Actually put the header files in the package. Oops. scm (5d3-1) unstable; urgency=low * New upstream. (Closes: #74761) * Make (terms) use new license location. * Make use libregexx rather than librx. * Fix build depends for above. * Using new regex lib seems to fix crash (Closes: #66787) * Consider adding scm-dev package with headers, but instead just add the headers to the scm package. (Closes: #70787) * Add doc-base support.
Diffstat (limited to 'x.h')
-rw-r--r--x.h19
1 files changed, 16 insertions, 3 deletions
diff --git a/x.h b/x.h
index 1207e6a..4423211 100644
--- a/x.h
+++ b/x.h
@@ -5,7 +5,9 @@ SCM make_xdisplay(Display *d);
SCM make_xgcontext(SCM d, int screen_number, GC gc, int rootp);
SCM make_xcursor(SCM display, Cursor cursor);
SCM make_xfont(SCM display, Font font, SCM name);
-SCM make_xvisual(Visual *vsl);
+SCM make_xvisual(XVisualInfo *vsl);
+SCM CCC2SCM_P(XcmsCCC ccc);
+SCM CCC2SCM(XcmsCCC ccc);
SCM make_xevent(XEvent *e);
size_t x_free_xevent(CELLPTR ptr);
void scm2XPoint(int signp, SCM dat, XPoint *ipr, char *pos, char *s_caller);
@@ -25,8 +27,10 @@ SCM x_display_debug(SCM sd, SCM si);
SCM x_default_screen(SCM sdpy);
SCM x_create_window(SCM swin, SCM spos, SCM sargs);
SCM x_create_pixmap(SCM obj, SCM s_size, SCM s_depth);
+SCM x_window_ref(SCM oargs);
SCM x_window_set(SCM args);
SCM x_window_geometry(SCM swin);
+SCM x_window_geometry_set(SCM args);
SCM x_close(SCM obj);
SCM x_flush(SCM sd, SCM si);
SCM x_create_colormap(SCM swin, SCM s_vis, SCM s_alloc);
@@ -38,7 +42,6 @@ SCM x_find_color(SCM scmap, SCM dat);
SCM x_color_set(SCM scmap, SCM s_pix, SCM dat);
SCM x_color_ref(SCM scmap, SCM sidx);
SCM x_map_window(SCM swin);
-SCM x_map_raised(SCM swin);
SCM x_map_subwindows(SCM swin);
SCM x_unmap_window(SCM swin);
SCM x_unmap_subwindows(SCM swin);
@@ -65,14 +68,21 @@ SCM x_screen_size(SCM sd, SCM si);
SCM x_screen_dimm(SCM sd, SCM si);
SCM x_screen_black(SCM sd, SCM si);
SCM x_screen_white(SCM sd, SCM si);
+XVisualInfo *visual2visualinfo(Display *dsp, Visual *vis);
SCM x_make_visual(SCM sd, SCM sdepth, SCM sclass);
+SCM x_visual_geometry(SCM svsl);
+SCM x_visual_class(SCM svsl);
SCM x_root_window(SCM sdpy, SCM sscr);
SCM x_default_colormap(SCM sdpy, SCM sscr);
SCM x_default_gcontext(SCM sdpy, SCM sscr);
SCM x_default_visual(SCM sdpy, SCM sscr);
+SCM x_default_ccc(SCM sdpy, SCM sscr);
+SCM x_propdata2scm(Atom type, int format, unsigned long nitems, unsigned char *data);
+SCM x_get_window_property(SCM swin, SCM sprop, SCM sargs);
+SCM x_list_properties(SCM swin);
SCM x_clear_area(SCM swin, SCM spos, SCM sargs);
SCM x_fill_rectangle(SCM swin, SCM sgc, SCM sargs);
-void xldraw_string(SCM sdbl, SCM sgc, SCM sargs, int (*proc)(), char *s_caller);
+void xldraw_string(SCM sdbl, SCM sgc, SCM sargs, int (*proc)(void), char *s_caller);
SCM x_draw_string(SCM sdbl, SCM sgc, SCM sargs);
SCM x_image_string(SCM sdbl, SCM sgc, SCM sargs);
SCM x_draw_points(SCM sdbl, SCM sgc, SCM sargs);
@@ -80,7 +90,10 @@ SCM xldraw_lines(SCM sdbl, SCM sgc, SCM sargs, int funcod, char *s_caller);
SCM x_draw_segments(SCM sdbl, SCM sgc, SCM sargs);
SCM x_draw_lines(SCM sdbl, SCM sgc, SCM sargs);
SCM x_fill_poly(SCM sdbl, SCM sgc, SCM sargs);
+SCM x_read_bitmap_file(SCM sdbl, SCM sfname);
SCM x_make_bool(int f);
SCM x_event_ref(SCM sevent, SCM sfield);
+SCM x_event_keysym(SCM sevent);
+char *xvisualclass2name(int class);
void x_scm_final(void);
void init_x(void);