summaryrefslogtreecommitdiffstats
path: root/unif.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /unif.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'unif.c')
-rw-r--r--unif.c40
1 files changed, 20 insertions, 20 deletions
diff --git a/unif.c b/unif.c
index b84e9e3..e65ca21 100644
--- a/unif.c
+++ b/unif.c
@@ -1,4 +1,4 @@
-/* Copyright (C) 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997, 2002 Free Software Foundation, Inc.
+/* Copyright (C) 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997, 2002, 2006 Free Software Foundation, Inc.
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -1338,12 +1338,12 @@ SCM lcount(item, seq)
w <<= LONG_BIT-1-(ubnd%LONG_BIT);
w >>= LONG_BIT-1-(ubnd%LONG_BIT); /* There may be only a partial word. */
while (imin < i--) {
- for(;w;w >>= 4) cnt += cnt_tab[w & 0x0f];
+ for (;w;w >>= 4) cnt += cnt_tab[w & 0x0f];
w = VELTS(seq)[i];
if (FALSEP(item)) w = ~w;
}
w >>= (lbnd%LONG_BIT);
- for(;w;w >>= 4) cnt += cnt_tab[w & 0x0f];
+ for (;w;w >>= 4) cnt += cnt_tab[w & 0x0f];
return MAKINUM(cnt);
case tc7_smob:
ASRTGO(ARRAYP(seq) && 1==ARRAY_NDIM(seq) && 0==enclosed++, badarg2);
@@ -1526,7 +1526,7 @@ SCM bit_count(v, kv, obj)
k = VELTS(kv)[i] & (obj ? VELTS(v)[i] : ~VELTS(v)[i]);
k <<= LONG_BIT-1-((LENGTH(v)-1)%LONG_BIT);
while (!0) {
- for(;k;k >>= 4) count += cnt_tab[k & 0x0f];
+ for (;k;k >>= 4) count += cnt_tab[k & 0x0f];
if (0==i--) return MAKINUM(count);
k = VELTS(kv)[i] & (obj ? VELTS(v)[i] : ~VELTS(v)[i]);
}
@@ -1825,11 +1825,11 @@ static void rapr1(ra, j, k, port, writing)
case tc7_smob:
if (enclosed++) {
ARRAY_BASE(ra) = j;
- if (n-- > 0) iprin1(ra, port, writing);
+ if (n-- > 0) scm_iprin1(ra, port, writing);
for (j += inc; n-- > 0; j += inc) {
lputc(' ', port);
ARRAY_BASE(ra) = j;
- iprin1(ra, port, writing);
+ scm_iprin1(ra, port, writing);
}
break;
}
@@ -1858,18 +1858,18 @@ static void rapr1(ra, j, k, port, writing)
ra = ARRAY_V(ra);
goto tail;
default:
- if (n-- > 0) iprin1(cvref(ra, j, UNDEFINED), port, writing);
+ if (n-- > 0) scm_iprin1(cvref(ra, j, UNDEFINED), port, writing);
for (j += inc; n-- > 0; j += inc) {
lputc(' ', port);
- iprin1(cvref(ra, j, UNDEFINED), port, writing);
+ scm_iprin1(cvref(ra, j, UNDEFINED), port, writing);
}
break;
case tc7_string:
- if (n-- > 0) iprin1(MAKICHR(CHARS(ra)[j]), port, writing);
+ if (n-- > 0) scm_iprin1(MAKICHR(CHARS(ra)[j]), port, writing);
if (writing)
for (j += inc; n-- > 0; j += inc) {
lputc(' ', port);
- iprin1(MAKICHR(CHARS(ra)[j]), port, writing);
+ scm_iprin1(MAKICHR(CHARS(ra)[j]), port, writing);
}
else
for (j += inc; n-- > 0; j += inc)
@@ -1877,20 +1877,20 @@ static void rapr1(ra, j, k, port, writing)
break;
case tc7_VfixN32:
if (errjmp_bad) {
- ipruk("VfixN32", ra, port);
+ scm_ipruk("VfixN32", ra, port);
break;
}
- if (n-- > 0) intprint(VELTS(ra)[j], -10, port);
+ if (n-- > 0) scm_intprint(VELTS(ra)[j], -10, port);
for (j += inc; n-- > 0; j += inc) {
lputc(' ', port);
- intprint(VELTS(ra)[j], -10, port);
+ scm_intprint(VELTS(ra)[j], -10, port);
}
break;
case tc7_VfixZ32:
- if (n-- > 0) intprint(VELTS(ra)[j], 10, port);
+ if (n-- > 0) scm_intprint(VELTS(ra)[j], 10, port);
for (j += inc; n-- > 0; j += inc) {
lputc(' ', port);
- intprint(VELTS(ra)[j], 10, port);
+ scm_intprint(VELTS(ra)[j], 10, port);
}
break;
# ifdef FLOATS
@@ -1932,7 +1932,7 @@ int raprin1(exp, port, writing)
return 1;
}
else {
- intprint(ndim, 10, port);
+ scm_intprint(ndim, 10, port);
goto tail;
}
}
@@ -1940,9 +1940,9 @@ int raprin1(exp, port, writing)
if (exp==v) { /* a uve, not an array */
register long i, j, w;
lputc('*', port);
- for(i = 0;i<(LENGTH(exp))/LONG_BIT;i++) {
+ for (i = 0;i<(LENGTH(exp))/LONG_BIT;i++) {
w = VELTS(exp)[i];
- for(j = LONG_BIT;j;j--) {
+ for (j = LONG_BIT;j;j--) {
lputc(w&1?'1':'0', port);
w >>= 1;
}
@@ -1950,7 +1950,7 @@ int raprin1(exp, port, writing)
j = LENGTH(exp)%LONG_BIT;
if (j) {
w = VELTS(exp)[LENGTH(exp)/LONG_BIT];
- for(;j;j--) {
+ for (;j;j--) {
lputc(w&1?'1':'0', port);
w >>= 1;
}
@@ -1992,7 +1992,7 @@ int raprin1(exp, port, writing)
}
if ((v != exp) && 0==ARRAY_NDIM(exp)) {
lputc(' ', port);
- iprin1(aref(exp, EOL), port, writing);
+ scm_iprin1(aref(exp, EOL), port, writing);
}
else {
lputc('(', port);