summaryrefslogtreecommitdiffstats
path: root/time.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2006-10-23 23:31:59 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commit906cc4f0899080f1b832af98b7ccbcc257b8a64e (patch)
tree14e3ec231debdca4da9c1a3ccc0536033c1c8a4b /time.c
parent3d573fa54db0fdcae8b2a20356faa46c8e335206 (diff)
parent50eb784bfcf15ee3c6b0b53d747db92673395040 (diff)
downloadscm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.tar.gz
scm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.zip
Import Debian changes 5e3-1debian/5e3-1
scm (5e3-1) unstable; urgency=low * New upstream release. * debian/control (Architecture): Add ia64 to list of supported archs. Now everything but s390 is listed. (Closes: #335980) (Build-Depends): Require at least version 3a4 of slib. * Change to continue.h from version 5e1-2 repeated here. * Change to xgen.scm from version 5e2-4 repeated here. * Change to scm.1 from version 5e2-4 repeated here.
Diffstat (limited to 'time.c')
-rw-r--r--time.c47
1 files changed, 26 insertions, 21 deletions
diff --git a/time.c b/time.c
index abb5684..75bf603 100644
--- a/time.c
+++ b/time.c
@@ -101,6 +101,9 @@
# include <sys/types.h>
# include <sys/time.h>
# include <sys/timeb.h>
+# include <sys/times.h>
+# include <unistd.h>
+# define CLKTCK (sysconf(_SC_CLK_TCK))
# define USE_GETTIMEOFDAY
#endif
#ifdef __MACH__
@@ -153,8 +156,8 @@
# define LACK_FTIME
#endif
#ifdef PLAN9
-#define LACK_FTIME
-#define LACK_TIMES
+# define LACK_FTIME
+# define LACK_TIMES
#endif
#ifdef nosve
# define LACK_FTIME
@@ -219,30 +222,32 @@
# define LACK_FTIME
#endif
-#ifdef CLK_TCK
-# define CLKTCK CLK_TCK
-# ifdef CLOCKS_PER_SEC
-# ifdef HAVE_UNIX
-# ifndef ARM_ULIB
-# include <sys/times.h>
-# endif
-# define LACK_CLOCK
+#ifndef CLKTCK
+# ifdef CLK_TCK
+# define CLKTCK CLK_TCK
+# ifdef CLOCKS_PER_SEC
+# ifdef HAVE_UNIX
+# ifndef ARM_ULIB
+# include <sys/times.h>
+# endif
+# define LACK_CLOCK
/* This is because clock() might be POSIX rather than ANSI.
This occurs on HP-UX machines */
+# endif
# endif
-# endif
-#else
-# ifdef CLOCKS_PER_SEC
-# define CLKTCK CLOCKS_PER_SEC
# else
-# define LACK_CLOCK
-# ifdef AMIGA
-# include <stddef.h>
-# define LACK_TIMES
-# define LACK_FTIME
-# define CLKTCK 1000
+# ifdef CLOCKS_PER_SEC
+# define CLKTCK CLOCKS_PER_SEC
# else
-# define CLKTCK 60
+# define LACK_CLOCK
+# ifdef AMIGA
+# include <stddef.h>
+# define LACK_TIMES
+# define LACK_FTIME
+# define CLKTCK 1000
+# else
+# define CLKTCK 60
+# endif
# endif
# endif
#endif