summaryrefslogtreecommitdiffstats
path: root/scmhob.h
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /scmhob.h
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'scmhob.h')
-rw-r--r--scmhob.h8
1 files changed, 4 insertions, 4 deletions
diff --git a/scmhob.h b/scmhob.h
index b1480c1..1e8e961 100644
--- a/scmhob.h
+++ b/scmhob.h
@@ -1,5 +1,5 @@
/* scmhob.h is a header file for scheme source compiled with hobbit5x
- Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997 Tanel Tammet
+ Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997 Tanel Tammet
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -76,9 +76,9 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111, USA.
#define BOOLEAN_P(x) ((x)==BOOL_T || (x)==BOOL_F)
#define CHAR_P ICHRP
-#define SYMBOL_P(x) (ISYMP(x) || (!(IMP(x)) && SYMBOLP(x)))
-#define VECTOR_P(x) (!(IMP(x)) && VECTORP(x))
-#define PAIR_P(x) (!(IMP(x)) && CONSP(x))
+#define SYMBOL_P(x) (ISYMP(x) || (!(IMP(x)) && SYMBOLP(x)))
+#define VECTOR_P(x) (!(IMP(x)) && VECTORP(x))
+#define PAIR_P(x) (!(IMP(x)) && CONSP(x))
#define NUMBER_P INUMP
#define INTEGER_P INUMP
#define STRING_P(x) (!(IMP(x)) && STRINGP(x))