summaryrefslogtreecommitdiffstats
path: root/rope.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /rope.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'rope.c')
-rw-r--r--rope.c18
1 files changed, 9 insertions, 9 deletions
diff --git a/rope.c b/rope.c
index 6f48982..d4fc16a 100644
--- a/rope.c
+++ b/rope.c
@@ -1,4 +1,4 @@
-/* Copyright (C) 1990, 1991, 1992, 1993, 1994, 1995, 1997 Free Software Foundation, Inc.
+/* Copyright (C) 1990, 1991, 1992, 1993, 1994, 1995, 1997, 2006 Free Software Foundation, Inc.
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -121,7 +121,7 @@ unsigned long num2ulong(num, pos, s_caller)
sizet l = NUMDIGS(num);
ASRTGO(DIGSPERLONG >= l, errout);
res = 0;
- for(;l--;) res = BIGUP(res) + BDIGITS(num)[l];
+ for (;l--;) res = BIGUP(res) + BDIGITS(num)[l];
return res;
}
#endif
@@ -152,7 +152,7 @@ long num2long(num, pos, s_caller)
sizet l = NUMDIGS(num);
ASRTGO(DIGSPERLONG >= l, errout);
res = 0;
- for(;l--;) res = BIGUP(res) + BDIGITS(num)[l];
+ for (;l--;) res = BIGUP(res) + BDIGITS(num)[l];
ASRTGO(0<res, errout);
return (tc16_bigpos==TYP16(num) ? res : -res);
}
@@ -219,7 +219,7 @@ SCM makfromstrs(argc, argv)
{
int i = argc;
SCM lst = EOL;
- if (0 > i) for(i = 0; argv[i]; i++);
+ if (0 > i) for (i = 0; argv[i]; i++);
while (i--) lst = cons(makfrom0str(argv[i]), lst);
return lst;
}
@@ -232,7 +232,7 @@ char **makargvfrmstrs(args, s_name)
char ** argv;
int argc = ilength(args);
argv = (char **)must_malloc((1L+argc)*sizeof(char *), s_vector);
- for(argc = 0; NNULLP(args); args=CDR(args), ++argc) {
+ for (argc = 0; NNULLP(args); args=CDR(args), ++argc) {
ASRTER(NIMP(CAR(args)) && STRINGP(CAR(args)), CAR(args), ARG2, s_name);
{
sizet len = 1 + LENGTH(CAR(args));
@@ -246,10 +246,10 @@ char **makargvfrmstrs(args, s_name)
return argv;
}
void must_free_argv(argv)
- const char * const *argv;
+ char **argv;
{
sizet i;
- for(i = 0; argv[i]; i++) {
+ for (i = 0; argv[i]; i++) {
must_free(argv[i], 1+strlen(argv[i]));
}
must_free((char *)argv, i*sizeof(char *));
@@ -295,7 +295,7 @@ int scm_ldprog(path)
long aind P((SCM ra, SCM args, const char *what));
unsigned long scm_addr(args, s_name)
SCM args;
- char *s_name;
+ const char *s_name;
{
long pos;
unsigned long ptr = 0; /* gratuitous assignment squelches cc warn. */
@@ -356,7 +356,7 @@ unsigned long scm_addr(args, s_name)
}
unsigned long scm_base_addr(v, s_name)
SCM v;
- char *s_name;
+ const char *s_name;
{
long pos = 0;
unsigned long ptr = 0; /* gratuitous assignment squelches cc warn. */