summaryrefslogtreecommitdiffstats
path: root/rgx.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /rgx.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'rgx.c')
-rw-r--r--rgx.c10
1 files changed, 5 insertions, 5 deletions
diff --git a/rgx.c b/rgx.c
index 1f3b4f0..81af5c4 100644
--- a/rgx.c
+++ b/rgx.c
@@ -55,7 +55,7 @@
#endif
static char rcsid[] =
- "$Id: rgx.c,v 1.16 2002/11/25 20:34:31 jaffer Exp $";
+ "$Id: rgx.c,v 1.18 2007/11/24 19:56:56 jaffer Exp $";
#ifdef HAVE_ALLOCA
# include <alloca.h>
@@ -135,9 +135,9 @@ int prinregex(exp, port, writing)
SCM exp; SCM port; int writing;
{
lputs("#<regex ", port);
- intprint(CDR(exp), -16, port);
+ scm_intprint(CDR(exp), -16, port);
lputc(' ', port);
- iprin1(RGX_PATTERN(exp), port, writing);
+ scm_iprin1(RGX_PATTERN(exp), port, writing);
lputc('>', port);
return 1;
}
@@ -201,12 +201,12 @@ SCM lregcomp(pattern, flags)
info=(regex_info*)CHARS(z);
prog = &(info->rgx);
#ifdef __REGEXP_LIBRARY_H__
- for(i=sizeof(regex_t);i--;((char *)prog)[i] = 0);
+ for (i=sizeof(regex_t);i--;((char *)prog)[i] = 0);
# ifndef _GNU_SOURCE
{
regex_t *prog2;
prog2 = &(info->rgx_anchored);
- for(i=sizeof(regex_t);i--;((char *)prog2)[i] = 0);
+ for (i=sizeof(regex_t);i--;((char *)prog2)[i] = 0);
}
# endif
#endif