summaryrefslogtreecommitdiffstats
path: root/repl.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2005-10-26 19:31:02 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:28 -0800
commit5f7b0413c1bb0f96bb613ad74c0978f44116a136 (patch)
treefa4a4e8097af22dfcb5c8dba8eed67aabfe76599 /repl.c
parent37f2f5e0bb11a18deecf48c7ad6bcbf7bd932db2 (diff)
downloadscm-5f7b0413c1bb0f96bb613ad74c0978f44116a136.tar.gz
scm-5f7b0413c1bb0f96bb613ad74c0978f44116a136.zip
Import Debian changes 5d9-5debian/5d9-5
scm (5d9-5) unstable; urgency=low * New maintainer. Adopted with permission of previous maintainer. * repl.c (s_read): Remove static qualifier on declaration. * scmfig.h: Use SHORT_INT and CDR_DOUBLES on __powerpc64__ and __x86_64__ just as with __ia64. (Closes: #295074, #251765) * debian/control (Build-Depends): Use libreadline5-dev in place of libreadline4-dev. (Closes: #326297)
Diffstat (limited to 'repl.c')
-rw-r--r--repl.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/repl.c b/repl.c
index 07b357c..c04d230 100644
--- a/repl.c
+++ b/repl.c
@@ -849,7 +849,7 @@ static int flush_ws(port)
/* Top-level readers */
static SCM p_read_numbered, p_read_for_load, p_read;
-static char s_read[] = "read";
+char s_read[] = "read";
static char s_read_for_load[] = "read-for-load";
static char s_read_numbered[] = "read-numbered";
SCM scm_read(port)