summaryrefslogtreecommitdiffstats
path: root/record.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /record.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'record.c')
-rw-r--r--record.c22
1 files changed, 11 insertions, 11 deletions
diff --git a/record.c b/record.c
index de72dce..30fa677 100644
--- a/record.c
+++ b/record.c
@@ -133,7 +133,7 @@ SCM rec_constr(rtd, flds)
i = ilength(flds);
ASRTER(i>=0, flds, ARG2, s_rec_constr);
indices = MAKE_REC_INDS(i);
- for(i = 0; NIMP(flds); i++, flds = CDR(flds)) {
+ for (i = 0; NIMP(flds); i++, flds = CDR(flds)) {
fld = CAR(flds);
ASRTER(NIMP(fld) && SYMBOLP(fld), fld, ARG2, s_rec_constr);
flst = RTD_FIELDS(rtd);
@@ -319,26 +319,26 @@ static int recprin1(exp, port, writing)
}
names = RTD_FIELDS(REC_RTD(exp));
lputs("#s(", port);
- iprin1(RTD_NAME(REC_RTD(exp)), port, 0);
+ scm_iprin1(RTD_NAME(REC_RTD(exp)), port, 0);
if (writing) {
lputc(':', port);
- intprint(((long)REC_RTD(exp))>>1, 16, port);
+ scm_intprint(((long)REC_RTD(exp))>>1, 16, port);
}
for (i = 1; i < NUMDIGS(exp); i++) {
lputc(' ', port);
- iprin1(CAR(names), port, 0);
+ scm_iprin1(CAR(names), port, 0);
names = CDR(names);
lputc(' ', port);
- iprin1(VELTS(exp)[i], port, writing);
+ scm_iprin1(VELTS(exp)[i], port, writing);
}
lputc(')', port);
/*
lputs("#<record <", port);
- iprin1(RTD_NAME(REC_RTD(exp)), port, 0);
+ scm_iprin1(RTD_NAME(REC_RTD(exp)), port, 0);
lputc('>', port);
- for(i = 1; i < NUMDIGS(exp); i++) {
+ for (i = 1; i < NUMDIGS(exp); i++) {
lputc(' ', port);
- iprin1(VELTS(exp)[i], port, writing);
+ scm_iprin1(VELTS(exp)[i], port, writing);
}
lputc('>', port);
*/
@@ -350,11 +350,11 @@ SCM rec_rtdprin1(rtd, port, writing_p)
SCM rtd, port, writing_p;
{
lputs("#s(record-type ", port);
- iprin1(RTD_NAME(rtd), port, 0);
+ scm_iprin1(RTD_NAME(rtd), port, 0);
lputc(':', port);
- intprint(((long)rtd)>>1, 16, port);
+ scm_intprint(((long)rtd)>>1, 16, port);
lputs(" fields ", port);
- iprin1(RTD_FIELDS(rtd), port, 0);
+ scm_iprin1(RTD_FIELDS(rtd), port, 0);
if (NIMP(RTD_PRINTER(rtd)))
lputs(" P)", port);
else