aboutsummaryrefslogtreecommitdiffstats
path: root/ramap.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-02-04 20:53:13 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:41 -0800
commite9ed1ad5236ca6314136c4220ac672167b643fc5 (patch)
tree5b3d3a3b8c604225515a3ac6b09b6d036b14d165 /ramap.c
parent4bf8faaea412b017e299fd17a1b736119c86f18c (diff)
parent90889a692076f2c62486607d0354e0fca52364bc (diff)
downloadscm-e9ed1ad5236ca6314136c4220ac672167b643fc5.tar.gz
scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.zip
Import Debian changes 5e5-1debian/5e5-1
scm (5e5-1) unstable; urgency=low * New upstream release. * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5. * Makefile: Repeat change from 5e3-2. * debian/control (Build-Depends): Require at least version 3b1 of slib. (scm Depends): Likewise. (libscm-dev Depends): Likewise. * Makefile (scm.info): Add explicit dependency on features.txi and platform.txi. For some reason the one through $(texifiles) is failing mysteriously. Perhaps this is a make bug.
Diffstat (limited to 'ramap.c')
-rw-r--r--ramap.c52
1 files changed, 14 insertions, 38 deletions
diff --git a/ramap.c b/ramap.c
index ad3a74e..0cedfad 100644
--- a/ramap.c
+++ b/ramap.c
@@ -1,46 +1,22 @@
-/* Copyright (C) 1994, 1995, 2006 Free Software Foundation, Inc.
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this software; see the file COPYING. If not, write to
- * the Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111, USA.
- *
- * As a special exception, the Free Software Foundation gives permission
- * for additional uses of the text contained in its release of SCM.
- *
- * The exception is that, if you link the SCM library with other files
- * to produce an executable, this does not by itself cause the
- * resulting executable to be covered by the GNU General Public License.
- * Your use of that executable is in no way restricted on account of
- * linking the SCM library code into it.
+/* "ramap.c" Array mapping functions for APL-Scheme.
+ * Copyright (C) 1994, 1995, 2006 Free Software Foundation, Inc.
*
- * This exception does not however invalidate any other reasons why
- * the executable file might be covered by the GNU General Public License.
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License as
+ * published by the Free Software Foundation, either version 3 of the
+ * License, or (at your option) any later version.
*
- * This exception applies only to the code released by the
- * Free Software Foundation under the name SCM. If you copy
- * code from other Free Software Foundation releases into a copy of
- * SCM, as the General Public License permits, the exception does
- * not apply to the code that you add in this way. To avoid misleading
- * anyone as to the status of such modified files, you must delete
- * this exception notice from them.
+ * This program is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
*
- * If you write modifications of your own for SCM, it is your choice
- * whether to permit this exception to apply to your modifications.
- * If you do not wish that, delete this exception notice.
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this program. If not, see
+ * <http://www.gnu.org/licenses/>.
*/
-/* "ramap.c" Array mapping functions for APL-Scheme.
- Author: Radey Shouman */
+/* Author: Radey Shouman */
#include "scm.h"