summaryrefslogtreecommitdiffstats
path: root/posix.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2006-10-23 23:31:59 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commit906cc4f0899080f1b832af98b7ccbcc257b8a64e (patch)
tree14e3ec231debdca4da9c1a3ccc0536033c1c8a4b /posix.c
parent3d573fa54db0fdcae8b2a20356faa46c8e335206 (diff)
parent50eb784bfcf15ee3c6b0b53d747db92673395040 (diff)
downloadscm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.tar.gz
scm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.zip
Import Debian changes 5e3-1debian/5e3-1
scm (5e3-1) unstable; urgency=low * New upstream release. * debian/control (Architecture): Add ia64 to list of supported archs. Now everything but s390 is listed. (Closes: #335980) (Build-Depends): Require at least version 3a4 of slib. * Change to continue.h from version 5e1-2 repeated here. * Change to xgen.scm from version 5e2-4 repeated here. * Change to scm.1 from version 5e2-4 repeated here.
Diffstat (limited to 'posix.c')
-rw-r--r--posix.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/posix.c b/posix.c
index e6dab25..06e6b5f 100644
--- a/posix.c
+++ b/posix.c
@@ -154,7 +154,7 @@ SCM scm_getgroups()
The length needs not be exactly right */
grps = must_malloc_cell((0L + ngroups) * sizeof(gid_t),
MAKE_LENGTH(((0L + ngroups) * sizeof(gid_t))/sizeof(long),
- tc7_uvect),
+ tc7_VfixN32),
scm_s_getgroups);
ALLOW_INTS;
{