summaryrefslogtreecommitdiffstats
path: root/ioext.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /ioext.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'ioext.c')
-rw-r--r--ioext.c47
1 files changed, 2 insertions, 45 deletions
diff --git a/ioext.c b/ioext.c
index 62efc2b..9f4ada7 100644
--- a/ioext.c
+++ b/ioext.c
@@ -193,49 +193,8 @@ static char s_write_line[] = "write-line";
SCM l_write_line(obj, port)
SCM obj, port;
{
- display(obj, port);
- return newline(port);
-}
-
-static char s_file_position[] = "file-position",
- s_file_set_pos[] = "file-set-position";
-SCM file_position(port)
- SCM port;
-{
- long ans;
- ASRTER(NIMP(port) && OPFPORTP(port), port, ARG1, s_file_position);
- SYSCALL(ans = ftell(STREAM(port)););
- if (CRDYP(port)) ans--;
- return MAKINUM(ans);
- }
-SCM file_set_position(port, pos)
- SCM port, pos;
-{
- SCM ans;
- ASRTER(NIMP(port) && OPFPORTP(port), port, ARG1, s_file_set_pos);
-#ifndef RECKLESS
- if (TRACKED & SCM_PORTFLAGS(port)) {
- if (INUM0==pos) {
- int i = SCM_PORTNUM(port);
- scm_port_table[i].line = 1L;
- scm_port_table[i].col = 1;
- }
- else {
- if (2 <= verbose)
- scm_warn("Setting file position for tracked port: ", "", port);
- SCM_PORTFLAGS(port) &= (~TRACKED);
- }
- }
-#endif
- CLRDY(port); /* Clear ungetted char */
- SYSCALL(ans = (fseek(STREAM(port), INUM(pos), 0)) ? BOOL_F : BOOL_T;);
-#ifdef HAVE_PIPE
-# ifdef ESPIPE
- if (!OPIOPORTP(port))
- ASRTER(ESPIPE != errno, port, ARG1, s_file_set_pos);
-# endif
-#endif
- return ans;
+ scm_display(obj, port);
+ return scm_newline(port);
}
static char s_reopen_file[] = "reopen-file";
@@ -792,7 +751,6 @@ SCM l_putenv(str)
#endif
static iproc subr1s[] = {
- {s_file_position, file_position},
{s_fileno, l_fileno},
#ifndef MCH_AMIGA
# ifndef vms
@@ -877,7 +835,6 @@ SCM scm_try_create_file(fname, modes, perms)
#endif
static iproc subr2os[] = {
- {s_file_set_pos, file_set_position},
{s_read_line1, read_line1},
{s_write_line, l_write_line},
{0, 0}};