summaryrefslogtreecommitdiffstats
path: root/grtest.scm
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2005-10-27 12:00:49 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:29 -0800
commit4e063c0de0bf319c9201cefa6f399364041bb7b9 (patch)
tree61a326cd4ab69f610d2e10313db2a641b6d0b4dd /grtest.scm
parent5f7b0413c1bb0f96bb613ad74c0978f44116a136 (diff)
parent302e3218b7d487539ec305bf23881a6ee7d5be99 (diff)
downloadscm-4e063c0de0bf319c9201cefa6f399364041bb7b9.tar.gz
scm-4e063c0de0bf319c9201cefa6f399364041bb7b9.zip
Import Debian changes 5e1-1debian/5e1-1
scm (5e1-1) unstable; urgency=low * New upstream release. (Closes: #335970) * debian/rules (SCM_OPTIONS): Remove -F turtlegr; the file supporting this option seems to have gone by the wayside. * debian/rules (binary-arch): Don't try to install grtest.scm; it's gone now. * debian/rules (build-stamp): Use tee to capture output of ./build so that we can capture a copy of the file in the build log. * scm.1: Fix spelling errors in manual page: verobse -> verbose; qoutes -> quotes; aguments -> arguments; neccessary -> necessary; preceeds -> precedes. syncronization -> synchronization. (Closes: #300131) * debian/postinst, debian/prerm: Assume that install-docs is in the standard place, and test for it there with test -x. (Closes: #292996)
Diffstat (limited to 'grtest.scm')
-rw-r--r--grtest.scm82
1 files changed, 0 insertions, 82 deletions
diff --git a/grtest.scm b/grtest.scm
deleted file mode 100644
index 7401308..0000000
--- a/grtest.scm
+++ /dev/null
@@ -1,82 +0,0 @@
-
-; This is a quick hack to test the graphics primitives.
-; The SLIB scheme library is needed for random.
-; IMHO, the syntax of `do' in scheme is horrible!
-; - sjm
-
-(define (grtest)
- (require 'random) ; needs SLIB
- (graphics-mode!)
-
- (display "testing draw-to") (newline)
- (clear-graphics!)
- (goto-center!)
- (do ((x 0 (+ x 3)))
- ((> x (max-x)) 0)
- (set-color! (remainder (/ x 3) (max-color)))
- (draw-to x 0)
- (draw-to x (max-y))
- )
-
- (do ((y 0 (+ y 3)))
- ((> y (max-y)) 0)
- (set-color! (remainder (/ y 3) (max-color)))
- (goto-center!)
- (draw-to! 0 y)
- (goto-center!)
- (draw-to! (max-x) y)
- )
-
- (goto-nw!)
- (do ((x 0 (+ x 2)))
- ((> x (max-x)) 0)
- (set-color! (remainder (/ x 2) (max-color)))
- (draw-to x (max-y))
- )
- (do ((y (+ (max-y) 1) (- y 2)))
- ((< y 0) 0)
- (set-color! (remainder (/ y 2) (max-color)))
- (draw-to (max-x) y)
- )
-
- (display "testing set-dot!") (newline)
- (clear-graphics!)
- (do ((x 0 (+ x 1)))
- ((= x 100) 0)
- (set-dot! (+ (random (max-x)) 1) (+ (random (max-y)) 1)
- (+ (random (max-color)) 1))
- )
-
- (display "testing draw with turn-to!") (newline)
- (clear-graphics!)
- (goto-center!)
- (do ((x 0 (+ x 1)))
- ((= x 100) 0)
- (set-color! (+ (random (max-color)) 1))
- (turn-to! (random 360))
- (draw (random 50))
- )
-
- (display "testing draw with turn-right") (newline)
- (clear-graphics!)
- (goto-center!)
- (do ((x 0 (+ x 1)))
- ((= x 100) 0)
- (set-color! (+ (random (max-color)) 1))
- (turn-right (random 90))
- (draw (random 50))
- )
-
- (display "testing draw with turn-left") (newline)
- (clear-graphics!)
- (goto-center!)
- (do ((x 0 (+ x 1)))
- ((= x 100) 0)
- (set-color! (+ (random (max-color)) 1))
- (turn-left (random 90))
- (draw (random 50))
- )
-
- (text-mode!)
-)
-