summaryrefslogtreecommitdiffstats
path: root/findexec.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /findexec.c
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'findexec.c')
-rw-r--r--findexec.c19
1 files changed, 16 insertions, 3 deletions
diff --git a/findexec.c b/findexec.c
index 9769ef5..8edc6fc 100644
--- a/findexec.c
+++ b/findexec.c
@@ -43,6 +43,7 @@ Wed Feb 21 23:06:35 1996 Aubrey Jaffer
# include <sys/param.h>
# endif
# ifdef linux
+# include <string.h>
# include <stdlib.h>
# include <sys/stat.h>
# include <unistd.h> /* for X_OK define */
@@ -63,7 +64,7 @@ Wed Feb 21 23:06:35 1996 Aubrey Jaffer
# include <u.h>
# include <libc.h>
# define getcwd getwd
-# define MAXPATHLEN 256 /* arbitrary? */
+# define MAXPATHLEN 256 /* arbitrary? */
# define X_OK AEXEC
# else
# include <strings.h>
@@ -80,18 +81,30 @@ Wed Feb 21 23:06:35 1996 Aubrey Jaffer
# endif
# ifdef __FreeBSD__
/* This might be same for 44bsd derived system. */
-# include <sys/types.h>
+# include <stdlib.h>
+# include <string.h>
+# include <unistd.h>
+# include <sys/stat.h>
+# endif
+# ifdef __DragonflyBSD__
+/* This might be same for 44bsd derived system. */
+# include <stdlib.h>
+# include <string.h>
+# include <unistd.h>
# include <sys/stat.h>
# endif
# ifdef __NetBSD__
# include <stdlib.h>
+# include <string.h>
# include <unistd.h>
+# include <sys/stat.h>
# endif
# ifdef __OpenBSD__
/* This might be same for 44bsd derived system. */
# include <stdlib.h>
# include <unistd.h>
-# include <sys/types.h>
+# include <string.h>
+/* # include <sys/types.h> */
# include <sys/stat.h>
# endif
# ifdef __alpha