summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDavid N. Welton <davidw@efn.org>1998-12-11 20:21:49 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:25 -0800
commita47af30d2f0e96afcd1f14b1984575c359faa3d6 (patch)
tree2ed08ce2d757f917de7c3c7c04fd7e309f454c83 /debian
parentf64b2806c1d66a1341bb8b1491f384169ab1d65f (diff)
parentdb04688faa20f3576257c0fe41752ec435beab9a (diff)
downloadscm-a47af30d2f0e96afcd1f14b1984575c359faa3d6.tar.gz
scm-a47af30d2f0e96afcd1f14b1984575c359faa3d6.zip
Import Debian changes 5c3-5debian/5c3-5
scm (5c3-5) frozen unstable; urgency=low * debian/rules chmod +x's bld.scm. Fixes #30521. scm (5c3-4) frozen unstable; urgency=low * Made bld.scm executable. Fixes #29578. scm (5c3-3) frozen unstable; urgency=low * -nw * Fixes #16762. * Fixes #18163. * Fixes #18164. * Fixes #23743. * Fixes #24098. * Fixes #24099. * Fixes #24547. scm (5c3-2) frozen unstable; urgency=low * Re-uploading for slink freeze. scm (5c3-1) unstable; urgency=low * New upstream version.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog37
-rw-r--r--debian/control4
-rw-r--r--debian/postrm2
-rw-r--r--debian/require.scm.debian2
-rwxr-xr-xdebian/rules15
5 files changed, 49 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index ed01d96..c94c8fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,40 @@
+scm (5c3-5) frozen unstable; urgency=low
+
+ * debian/rules chmod +x's bld.scm. Fixes #30521.
+
+ -- David N. Welton <davidw@efn.org> Fri, 11 Dec 1998 20:21:49 -0800
+
+scm (5c3-4) frozen unstable; urgency=low
+
+ * Made bld.scm executable. Fixes #29578.
+
+ -- David N. Welton <davidw@efn.org> Mon, 30 Nov 1998 20:57:12 -0800
+
+scm (5c3-3) frozen unstable; urgency=low
+
+ * -nw
+ * Fixes #16762.
+ * Fixes #18163.
+ * Fixes #18164.
+ * Fixes #23743.
+ * Fixes #24098.
+ * Fixes #24099.
+ * Fixes #24547.
+
+ -- David N. Welton <davidw@efn.org> Mon, 9 Nov 1998 21:41:29 -0800
+
+scm (5c3-2) frozen unstable; urgency=low
+
+ * Re-uploading for slink freeze.
+
+ -- David N. Welton <davidw@efn.org> Mon, 2 Nov 1998 21:06:01 -0800
+
+scm (5c3-1) unstable; urgency=low
+
+ * New upstream version.
+
+ -- David N. Welton <davidw@efn.org> Thu, 29 Oct 1998 21:37:49 -0800
+
scm (5b3-1) unstable; urgency=low
* New maintainer
diff --git a/debian/control b/debian/control
index ef0a30b..9660bb5 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,8 @@
Source: scm
Section: devel
Priority: optional
-Maintainer: Rob Browning <rlb@cs.utexas.edu>
-Standards-Version: 2.1.1.2
+Maintainer: David N. Welton <davidw@efn.org>
+Standards-Version: 2.5.0.0
Package: scm
Architecture: any
diff --git a/debian/postrm b/debian/postrm
index 03e39ad..e7f4756 100644
--- a/debian/postrm
+++ b/debian/postrm
@@ -1,4 +1,4 @@
#!/bin/sh
set -e
-install-info --quiet --remove slib
+install-info --quiet --remove scm
diff --git a/debian/require.scm.debian b/debian/require.scm.debian
index d876879..06e43e6 100644
--- a/debian/require.scm.debian
+++ b/debian/require.scm.debian
@@ -1,2 +1,2 @@
-(define (library-vicinity) "/usr/lib/slib/")
+(define (library-vicinity) "/usr/share/slib/")
(load (in-vicinity (library-vicinity) "require"))
diff --git a/debian/rules b/debian/rules
index c3b6b26..07e44fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,21 +21,20 @@ SCM_OPTIONS = -p linux --compiler-options=-O2 --compiler-options=-g \
-F array-for-each \
-F inexact \
-F record \
- -F compiled-closure \
+ -F compiled-closure \
-F generalized-c-arguments \
-F tick-interrupts \
-F i/o-extensions \
-# -F turtlegr \
-F curses \
-F edit-line \
-F regex \
-F socket \
- -F posix \
+ -F posix \
-F unix \
-F dynamic-linking \
-F dump \
-F heap-can-shrink \
- -F macro
+ -F macro
NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
@@ -44,12 +43,14 @@ NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
# make checklit
build:
+ chmod +x bld.scm
$(checkdir)
+ cp debian/require.scm.debian require.scm
${MAKE} scmlit
- test -e /usr/lib/slib || \
+ test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
- cp debian/require.scm.debian require.scm
- SCHEME_LIBRARY_PATH=/usr/lib/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
+# SCHEME_LIBRARY_PATH=/usr/share/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
+ ./bld.scm ${SCM_OPTIONS} > debian/bld
chmod ug+x debian/bld
debian/bld
-rm -f debian/bld