aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2017-03-05 20:22:39 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-08-02 00:09:46 -0700
commitbd4815eb7993d86817dee456f2c97c82191eac4f (patch)
treedc8f284c3177637032b16df516b4a224199b19bf /debian/rules
parent69257a0530be17a6cf3c9427e0fdf337930f0428 (diff)
downloadscm-bd4815eb7993d86817dee456f2c97c82191eac4f.tar.gz
scm-bd4815eb7993d86817dee456f2c97c82191eac4f.zip
call configure directly; new init file; non-executable permissions
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ac0b297..ffeec60 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,7 +22,7 @@ override_dh_testdir:
(echo "Must have slib installed for compile" && exit 1)
override_dh_auto_configure:
- dh_auto_configure
+ ./configure
cp debian/require.scm.debian require.scm
cp debian/scm.opt.debian libscm.opt
@@ -40,4 +40,8 @@ override_dh_strip:
dh_strip --no-automatic-dbgsym
override_dh_auto_install:
+ # Make .scm scheme library scripts non-executable...
+ chmod a-x *.scm *.c
+ # except compile.scm
+ chmod a+x compile.scm
# skip; files listed explicitly