summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2003-05-07 08:36:40 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commite21d47d7813159bb71e0671df9b52ec0470c358d (patch)
tree3c7770ea846123c291f599044e9f234ac17616bb /debian/rules
parent8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff)
parentdeda2c0fd8689349fea2a900199a76ff7ecb319e (diff)
downloadscm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz
scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low * Fix hppa compile. Closes: #144062 scm (5d6-3.1) unstable; urgency=low * NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171 scm (5d6-3) unstable; urgency=low * Add build depend on xlibs-dev (Closes: #148020) scm (5d6-2) unstable; urgency=low * Remove libregexx-dev from build-depends. * Change build to use ./scmlit rather than scmlit (should fix some build problems) (looks like alpha is mostly building) * New release (Closes: #140175) * Built with turtlegraphics last time (Closes: #58515) scm (5d6-1) unstable; urgency=low * New upstream. * Add xlib and turtlegr to requested list of features. (closes some bug) * Make clean actually clean most everything up. * Remove hacks renaming build to something else and just set build as a .PHONY target in debian/rules. * Add the turtlegr code. scm (5d5-1) unstable; urgency=low * New upstream * Has fixes for 64 bit archs. May fix alpha compile problem. Does fix (Closes: #140175) * Take out -O2 arg. scm (5d4-3) unstable; urgency=low * Don't link with regexx, but just use libc6's regular expression functions. * Define (terms) to output /usr/share/common-licenses/GPL (Closes: #119321) scm (5d4-2) unstable; urgency=low * Add texinfo to build depends (Closes: #107011) scm (5d4-1) unstable; urgency=low * New upstream release. * Move install-info --remove to prerm. scm (5d3-5) unstable; urgency=low * Move scm info files to section "The Algorithmic Language Scheme" to match up with guile. scm (5d3-4) unstable; urgency=low * Fix build depends (Closes: #76691) scm (5d3-3) unstable; urgency=low * Fix path in scm dhelp file. scm (5d3-2) unstable; urgency=low * Actually put the header files in the package. Oops. scm (5d3-1) unstable; urgency=low * New upstream. (Closes: #74761) * Make (terms) use new license location. * Make use libregexx rather than librx. * Fix build depends for above. * Using new regex lib seems to fix crash (Closes: #66787) * Consider adding scm-dev package with headers, but instead just add the headers to the scm package. (Closes: #70787) * Add doc-base support.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules48
1 files changed, 29 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index bc0618f..da0e302 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# -*-Makefile-*-
CC =gcc
-CFLAGS =-O2 -g -Wall
+CFLAGS = -g -Wall
LDFLAGS =
SHELL =/bin/sh
@@ -17,12 +17,11 @@ INSTALL_MAN =$(INSTALL) -m 644 -o root -g root
ifeq ($(DEB_BUILD_ARCH), m68k)
COMPILER_OPTIONS=
else
-COMPILER_OPTIONS=-O2
+COMPILER_OPTIONS=
endif
SCM_OPTIONS = -p linux \
- --compiler-options=-g \
- --compiler-options=$(COMPILER_OPTIONS) \
+ --compiler-options="$(COMPILER_OPTIONS)" \
-F cautious \
-F bignums \
-F arrays \
@@ -40,46 +39,51 @@ SCM_OPTIONS = -p linux \
-F unix \
-F curses \
-F dynamic-linking \
+ -F turtlegr \
+ -F xlib \
-F dump \
-F macro
+# -F dump
+
# -F heap-can-shrink \
-NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
+NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm|grtest.scm'
#test: stamp-configure
# $(checkdir)
# make checklit
-build:
- chmod +x bld.scm
+build: build-stamp
+build-stamp:
+ chmod +x build
$(checkdir)
cp debian/require.scm.debian require.scm
ifeq ($(DEB_BUILD_ARCH), m68k)
- ${MAKE} scmlit CFLAGS=-g
+ ${MAKE} scmlit CFLAGS="-g -Wall"
else
${MAKE} scmlit
endif
test -e /usr/share/slib || \
- (echo "Must have slib installed for compile" && exit 1)
-# SCHEME_LIBRARY_PATH=/usr/share/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
- ./bld.scm ${SCM_OPTIONS} > debian/bld
+ (echo "Must have slib installed for compile" && exit 1)
+ ./build ${SCM_OPTIONS} > debian/bld
chmod ug+x debian/bld
debian/bld
- #-rm -f debian/bld
- #makeinfo scm.texi -o scm.info
make scm.info
texi2html -monolithic scm.texi
- touch build
+ touch build-stamp
clean:
$(checkdir)
- -rm scm.info* scm.html tmp1 tmp2 scmflags.h scmlit
+ -rm -f scm.info* scm.html tmp1 tmp2 scmflags.h scmlit
+ -rm -f features.txi platform.txi
-rm -f scm5d0.info
-rm require.scm scm
make distclean
- -rm -f build debian/bld
+ -rm -f srcdir.mk
+ -rm -f debian/bld
-rm -rf *~ debian/*~ debian/tmp* debian/files debian/substvars
+ -rm -f build-stamp
binary-indep: checkroot
$(checkdir)
@@ -93,7 +97,6 @@ binary-arch: checkroot build
$(INSTALL_DIR) debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/prerm debian/tmp/DEBIAN
- $(INSTALL_PROGRAM) debian/postrm debian/tmp/DEBIAN
# binaries
$(INSTALL_DIR) debian/tmp/usr/bin
@@ -103,7 +106,10 @@ binary-arch: checkroot build
$(INSTALL_DIR) debian/tmp/usr/lib/scm
$(INSTALL_DATA) `ls *.scm | egrep -v ${NON_LIB_FILES}` debian/tmp/usr/lib/scm
$(INSTALL_DATA) slibcat debian/tmp/usr/lib/scm
- chmod +x debian/tmp/usr/lib/scm/bld.scm
+
+# headers
+ $(INSTALL_DIR) debian/tmp/usr/include/scm
+ $(INSTALL_DATA) *.h debian/tmp/usr/include/scm
# man pages
$(INSTALL_DIR) debian/tmp/usr/share/man/man1
@@ -120,6 +126,9 @@ binary-arch: checkroot build
$(INSTALL_DATA) scm.html debian/tmp/usr/share/doc/scm
$(INSTALL_DATA) debian/copyright debian/tmp/usr/share/doc/scm
+ $(INSTALL_DIR) debian/tmp/usr/share/doc-base
+ $(INSTALL_DATA) debian/doc-base debian/tmp/usr/share/doc-base/scm
+
# examples
$(INSTALL_DIR) debian/tmp/usr/share/doc/scm/examples
$(INSTALL_DATA) r4rstest.scm debian/tmp/usr/share/doc/scm/examples
@@ -127,6 +136,7 @@ binary-arch: checkroot build
$(INSTALL_DATA) pi.scm debian/tmp/usr/share/doc/scm/examples
$(INSTALL_DATA) pi.c debian/tmp/usr/share/doc/scm/examples
$(INSTALL_DATA) bench.scm debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) grtest.scm debian/tmp/usr/share/doc/scm/examples
$(INSTALL_DATA) split.scm debian/tmp/usr/share/doc/scm/examples
# info pages
@@ -148,4 +158,4 @@ checkroot:
$(checkdir)
test root = "`whoami`"
-.PHONY: clean binary binary-arch binary-indep
+.PHONY: build clean binary binary-arch binary-indep