summaryrefslogtreecommitdiffstats
path: root/continue.h
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2005-10-28 17:24:42 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commit8e863293ba1c36b24f9441c4a5e9366cd66fe9c1 (patch)
tree39bd8964d3ea00742d12d687b5bf345d16ae7e23 /continue.h
parent4e063c0de0bf319c9201cefa6f399364041bb7b9 (diff)
downloadscm-8e863293ba1c36b24f9441c4a5e9366cd66fe9c1.tar.gz
scm-8e863293ba1c36b24f9441c4a5e9366cd66fe9c1.zip
Import Debian changes 5e1-2debian/5e1-2
scm (5e1-2) unstable; urgency=low * debian/control (Architecture): Provide explicit list: alpha amd64 arm hppa i386 i386-hurd m68k mips mipsel powerpc s390 sparc. This is all the Debian archs except for ia64, which is officially unspported by upstream. * continue.h: When __hppa__ is defined, set STACK_GROWS_UP.
Diffstat (limited to 'continue.h')
-rw-r--r--continue.h3
1 files changed, 3 insertions, 0 deletions
diff --git a/continue.h b/continue.h
index 040b4b5..2b412cd 100644
--- a/continue.h
+++ b/continue.h
@@ -196,3 +196,6 @@ void throw_to_continuation P((CONTINUATION *cont, long val,
#ifdef _UNICOS
# define STACK_GROWS_UP
#endif
+#ifdef __hppa__
+# define STACK_GROWS_UP
+#endif