summaryrefslogtreecommitdiffstats
path: root/bld.scm
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2003-05-07 08:36:40 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commite21d47d7813159bb71e0671df9b52ec0470c358d (patch)
tree3c7770ea846123c291f599044e9f234ac17616bb /bld.scm
parent8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff)
parentdeda2c0fd8689349fea2a900199a76ff7ecb319e (diff)
downloadscm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz
scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low * Fix hppa compile. Closes: #144062 scm (5d6-3.1) unstable; urgency=low * NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171 scm (5d6-3) unstable; urgency=low * Add build depend on xlibs-dev (Closes: #148020) scm (5d6-2) unstable; urgency=low * Remove libregexx-dev from build-depends. * Change build to use ./scmlit rather than scmlit (should fix some build problems) (looks like alpha is mostly building) * New release (Closes: #140175) * Built with turtlegraphics last time (Closes: #58515) scm (5d6-1) unstable; urgency=low * New upstream. * Add xlib and turtlegr to requested list of features. (closes some bug) * Make clean actually clean most everything up. * Remove hacks renaming build to something else and just set build as a .PHONY target in debian/rules. * Add the turtlegr code. scm (5d5-1) unstable; urgency=low * New upstream * Has fixes for 64 bit archs. May fix alpha compile problem. Does fix (Closes: #140175) * Take out -O2 arg. scm (5d4-3) unstable; urgency=low * Don't link with regexx, but just use libc6's regular expression functions. * Define (terms) to output /usr/share/common-licenses/GPL (Closes: #119321) scm (5d4-2) unstable; urgency=low * Add texinfo to build depends (Closes: #107011) scm (5d4-1) unstable; urgency=low * New upstream release. * Move install-info --remove to prerm. scm (5d3-5) unstable; urgency=low * Move scm info files to section "The Algorithmic Language Scheme" to match up with guile. scm (5d3-4) unstable; urgency=low * Fix build depends (Closes: #76691) scm (5d3-3) unstable; urgency=low * Fix path in scm dhelp file. scm (5d3-2) unstable; urgency=low * Actually put the header files in the package. Oops. scm (5d3-1) unstable; urgency=low * New upstream. (Closes: #74761) * Make (terms) use new license location. * Make use libregexx rather than librx. * Fix build depends for above. * Using new regex lib seems to fix crash (Closes: #66787) * Consider adding scm-dev package with headers, but instead just add the headers to the scm package. (Closes: #70787) * Add doc-base support.
Diffstat (limited to 'bld.scm')
-rw-r--r--bld.scm59
1 files changed, 0 insertions, 59 deletions
diff --git a/bld.scm b/bld.scm
deleted file mode 100644
index b12ecb9..0000000
--- a/bld.scm
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-:;exec ./scmlit -f $0 -e"(bi)" build $*
-
-(require 'build)
-(require 'getopt)
-(require 'getopt-parameters)
-
-(define (build-from-argv argv)
- (cond ((string? argv)
- (require 'read-command)
- (set! argv (call-with-input-string argv read-command))))
- (let ()
- (define command (string->symbol (list-ref argv *optind*)))
- (define argc (length argv))
- (cond
- ((pair? argv)
- (set! *optind* (+ 1 *optind*))
- ((make-command-server build '*commands*)
- command
- (lambda (comname comval options positions arities types
- defaulters checks aliases)
- (let* ((params (getopt->parameter-list
- argc argv options arities types aliases))
- (fparams (fill-empty-parameters defaulters params)))
- (cond ((not (list? params)) #f)
- ((not (check-parameters checks fparams)) #f)
- ((not (check-arities (map arity->arity-spec arities) fparams))
- (slib:error 'build-from-argv "arity error" fparams) #f)
- (else (comval fparams))))))))))
-
-(define (build-from-whole-argv argv)
- (set! *optind* 0)
- (set! *optarg* #f)
- (build-from-argv argv))
-
-(define b build-from-whole-argv)
-
-(define (b*)
- (require 'read-command)
- (do ((e (read-command) (read-command)))
- ((eof-object? e))
- (cond ((null? e))
- (else
- (cond ((not (string-ci=? (car e) "build"))
- (set! e (cons "build" e))))
- (write (build-from-whole-argv e))
- (newline)))
- (display "build> ")
- (force-output)))
-
-(define (bi) (build-from-argv *argv*))
-
-(cond (*interactive*
- (display "type (b \"build <command-line>\") to build") (newline)
- (display "type (b*) to enter build command loop") (newline)))
-
-;;; Local Variables:
-;;; mode:scheme
-;;; End: