summaryrefslogtreecommitdiffstats
path: root/bench.scm
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2006-10-23 23:31:59 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commit906cc4f0899080f1b832af98b7ccbcc257b8a64e (patch)
tree14e3ec231debdca4da9c1a3ccc0536033c1c8a4b /bench.scm
parent3d573fa54db0fdcae8b2a20356faa46c8e335206 (diff)
parent50eb784bfcf15ee3c6b0b53d747db92673395040 (diff)
downloadscm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.tar.gz
scm-906cc4f0899080f1b832af98b7ccbcc257b8a64e.zip
Import Debian changes 5e3-1debian/5e3-1
scm (5e3-1) unstable; urgency=low * New upstream release. * debian/control (Architecture): Add ia64 to list of supported archs. Now everything but s390 is listed. (Closes: #335980) (Build-Depends): Require at least version 3a4 of slib. * Change to continue.h from version 5e1-2 repeated here. * Change to xgen.scm from version 5e2-4 repeated here. * Change to scm.1 from version 5e2-4 repeated here.
Diffstat (limited to 'bench.scm')
-rw-r--r--bench.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/bench.scm b/bench.scm
index 0bcac0a..36255f0 100644
--- a/bench.scm
+++ b/bench.scm
@@ -98,7 +98,7 @@
))))))
(define (prng samples modu sta)
- (define sra (create-array (A:fixN32b) samples))
+ (define sra (make-array (A:fixN32b) samples))
(do ((cnt (+ -1 samples) (+ -1 cnt))
(num (random modu sta) (random modu sta))
(sum 0 (+ sum num)))