summaryrefslogtreecommitdiffstats
path: root/README
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2007-12-28 15:56:00 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:38 -0800
commit967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch)
tree8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /README
parent25fbaa7f8700665d5aea046956175a35035f7fd5 (diff)
parent710a97992705d67c3ded0d4b270c5978ce29b11f (diff)
downloadscm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz
scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low * New upstream release. * debian/control: Require at least version 3a5 of slib. * debian/postrm: New file to remove /usr/lib/scm/implcat and /usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar Appaiah for the fix. * debian/control (Architecture): Add armel and armeb. (Closes: #408792). * debian/rules (install): Don't use -s when installing. dh_strip should be sufficient, and this should make the nostrip build option work. (Closes: #438004). * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'README')
-rw-r--r--README23
1 files changed, 11 insertions, 12 deletions
diff --git a/README b/README
index 8266887..7c177fc 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This directory contains the distribution of scm5e3. Scm conforms to
+This directory contains the distribution of scm5e4. Scm conforms to
Revised^5 Report on the Algorithmic Language Scheme and the IEEE P1178
specification. SCM runs under Amiga, Atari-ST, MacOS, MS-DOS, OS/2,
NOS/VE, Unicos, VMS, Unix and similar systems.
@@ -26,6 +26,7 @@ NOS/VE, Unicos, VMS, Unix and similar systems.
`build.bat' invokes build.scm for MS-DOS
`build.scm' database for compiling and linking new SCM programs.
`byte.c' strings as bytes.
+`bytenumb.c' Byte-number conversions.
`compile.scm' Hobbit compilation to C.
`continue-ia64.S'replaces make_root_continuation(), make_continuation(),
and dynthrow() in continue.c
@@ -107,18 +108,16 @@ SLIB is not _neccessary_ to run SCM, I strongly suggest you obtain and
install it. Bug reports about running SCM without SLIB have very low
priority. SLIB is available from the same sites as SCM:
- * swiss.csail.mit.edu:/pub/scm/slib3a4.tar.gz
+ * swiss.csail.mit.edu:/pub/scm/slib3a5.tar.gz
- * ftp.gnu.org:/pub/gnu/jacal/slib3a4.tar.gz
+ * ftp.gnu.org:/pub/gnu/jacal/slib3a5.tar.gz
- * ftp.cs.indiana.edu:/pub/scheme-repository/imp/slib3a4.tar.gz
-
-Unpack SLIB (`tar xzf slib3a4.tar.gz' or `unzip -ao slib3a4.zip') in an
+Unpack SLIB (`tar xzf slib3a5.tar.gz' or `unzip -ao slib3a5.zip') in an
appropriate directory for your system; both `tar' and `unzip' will
create the directory `slib'.
Then create a file `require.scm' in the SCM "implementation-vicinity"
-(this is the same directory as where the file `Init5e3.scm' is
+(this is the same directory as where the file `Init5e4.scm' is
installed). `require.scm' should have the contents:
(define (library-vicinity) "/usr/local/lib/slib/")
@@ -149,7 +148,7 @@ File: scm.info, Node: Making SCM, Next: SLIB, Prev: Installing SCM, Up: Inst
The SCM distribution has "Makefile" which contains rules for making
"scmlit", a "bare-bones" version of SCM sufficient for running `build'.
`build' is used to compile (or create scripts to compile) full
-featured versions.
+featured versions (*note Building SCM::).
Makefiles are not portable to the majority of platforms. If `Makefile'
works for you, good; If not, I don't want to hear about it. If you
@@ -283,17 +282,17 @@ remove <FLAG> in scmfig.h and Do so and recompile files.
recompile scm.
add <FLAG> in scmfig.h and
recompile scm.
-ERROR: Init5e3.scm not found. Assign correct IMPLINIT in makefile
+ERROR: Init5e4.scm not found. Assign correct IMPLINIT in makefile
or scmfig.h.
Define environment variable
SCM_INIT_PATH to be the full
- pathname of Init5e3.scm.
+ pathname of Init5e4.scm.
WARNING: require.scm not found. Define environment variable
SCHEME_LIBRARY_PATH to be the full
pathname of the scheme library
[SLIB].
Change library-vicinity in
- Init5e3.scm to point to library or
+ Init5e4.scm to point to library or
remove.
Make sure the value of
(library-vicinity) has a trailing
@@ -354,7 +353,7 @@ Some symbol names print incorrectly. Change memory model option to C
than HEAP_SEG_SIZE).
ERROR: Rogue pointer in Heap. See above under machine crashes.
Newlines don't appear correctly in Check file mode (define OPEN_... in
-output files. `Init5e3.scm').
+output files. `Init5e4.scm').
Spaces or control characters appear Check character defines in
in symbol names. `scmfig.h'.
Negative numbers turn positive. Check SRS in `scmfig.h'.