summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2006-10-26 21:50:09 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commitb6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4 (patch)
treec0014260e8ce3ac5cf7cb80b231588b67bc4c4d3 /Makefile
parent906cc4f0899080f1b832af98b7ccbcc257b8a64e (diff)
downloadscm-b6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4.tar.gz
scm-b6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4.zip
Import Debian changes 5e3-2debian/5e3-2
scm (5e3-2) unstable; urgency=low * Makefile (ofiles): If $(ARCH) is ia64, add continue-ia64.o. * debian/rules: Set ARCH from DEB_BUILD_ARCH when making scmlit. (Closes: #395312)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 76d3c99..b1d511d 100644
--- a/Makefile
+++ b/Makefile
@@ -107,7 +107,9 @@ cfiles = scmmain.c scm.c time.c repl.c ioext.c scl.c sys.c eval.c \
findexec.c script.c debug.c byte.c differ.c
ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
continue.o findexec.o script.o debug.o
-# continue-ia64.o
+ifeq ($(ARCH),ia64)
+ofiles += continue-ia64.o
+endif
ifiles = Init$(VERSION).scm Transcen.scm Link.scm Macro.scm Macexp.scm \
Tscript.scm compile.scm Iedline.scm Idiffer.scm
hobfiles = hobbit.scm scmhob.scm scmhob.h