summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2006-10-26 21:50:09 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:35 -0800
commitb6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4 (patch)
treec0014260e8ce3ac5cf7cb80b231588b67bc4c4d3
parent906cc4f0899080f1b832af98b7ccbcc257b8a64e (diff)
downloadscm-b6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4.tar.gz
scm-b6fa723b20fab0d8e7970d5beaa152d0c9e1b4b4.zip
Import Debian changes 5e3-2debian/5e3-2
scm (5e3-2) unstable; urgency=low * Makefile (ofiles): If $(ARCH) is ia64, add continue-ia64.o. * debian/rules: Set ARCH from DEB_BUILD_ARCH when making scmlit. (Closes: #395312)
-rw-r--r--Makefile4
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules4
3 files changed, 13 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 76d3c99..b1d511d 100644
--- a/Makefile
+++ b/Makefile
@@ -107,7 +107,9 @@ cfiles = scmmain.c scm.c time.c repl.c ioext.c scl.c sys.c eval.c \
findexec.c script.c debug.c byte.c differ.c
ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
continue.o findexec.o script.o debug.o
-# continue-ia64.o
+ifeq ($(ARCH),ia64)
+ofiles += continue-ia64.o
+endif
ifiles = Init$(VERSION).scm Transcen.scm Link.scm Macro.scm Macexp.scm \
Tscript.scm compile.scm Iedline.scm Idiffer.scm
hobfiles = hobbit.scm scmhob.scm scmhob.h
diff --git a/debian/changelog b/debian/changelog
index 5be7a7f..c631754 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+scm (5e3-2) unstable; urgency=low
+
+ * Makefile (ofiles): If $(ARCH) is ia64, add continue-ia64.o.
+ * debian/rules: Set ARCH from DEB_BUILD_ARCH when making scmlit.
+ (Closes: #395312)
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Thu, 26 Oct 2006 21:50:09 -0700
+
scm (5e3-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/rules b/debian/rules
index 763f2a2..d5ea1e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -62,9 +62,9 @@ build-stamp:
dh_testdir
cp debian/require.scm.debian require.scm
ifeq ($(DEB_BUILD_ARCH), m68k)
- ${MAKE} scmlit CFLAGS="-g -Wall"
+ ${MAKE} scmlit CFLAGS="-g -Wall" ARCH=$(DEB_BUILD_ARCH)
else
- ${MAKE} scmlit
+ ${MAKE} scmlit ARCH=$(DEB_BUILD_ARCH)
endif
test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)