summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/gnutls/gnutls.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 3089979a0..43ec9777d 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -37,6 +37,11 @@ GNUTLS_CONF_OPT += --with-regex-header=pcreposix.h \
--with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
--with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
+# Consider crywrap as part of tools because it needs WCHAR, and it's so too
+ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
+ GNUTLS_CONF_OPT += --disable-crywrap
+endif
+
# libidn support for nommu must exclude the crywrap wrapper (uses fork)
GNUTLS_CONF_OPT += $(if $(BR2_USE_MMU),,--disable-crywrap)
GNUTLS_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBIDN),libidn)