summaryrefslogtreecommitdiffstats
path: root/package/xavante
diff options
context:
space:
mode:
Diffstat (limited to 'package/xavante')
-rw-r--r--package/xavante/Config.in14
-rw-r--r--package/xavante/xavante.mk23
2 files changed, 37 insertions, 0 deletions
diff --git a/package/xavante/Config.in b/package/xavante/Config.in
new file mode 100644
index 000000000..7a3535af3
--- /dev/null
+++ b/package/xavante/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_XAVANTE
+ bool "xavante"
+ depends on BR2_PACKAGE_LUA_SHARED_LIBRARY
+ select BR2_PACKAGE_CGILUA
+ select BR2_PACKAGE_COPAS
+ select BR2_PACKAGE_COXPCALL
+ select BR2_PACKAGE_LUAFILESYSTEM
+ select BR2_PACKAGE_LUASOCKET
+ select BR2_PACKAGE_WSAPI
+ help
+ Xavante is a Lua HTTP 1.1 Web server that uses a modular
+ architecture based on URI mapped handlers.
+
+ http://keplerproject.github.com/xavante/
diff --git a/package/xavante/xavante.mk b/package/xavante/xavante.mk
new file mode 100644
index 000000000..525b09f40
--- /dev/null
+++ b/package/xavante/xavante.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# xavante
+#
+#############################################################
+
+XAVANTE_VERSION = 2.2.0
+XAVANTE_SITE = http://github.com/downloads/keplerproject/xavante
+XAVANTE_DEPENDENCIES = cgilua copas coxpcall lua luafilesystem luasocket wsapi
+
+define XAVANTE_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) PREFIX=/usr \
+ LUA_DIR="$(TARGET_DIR)/usr/share/lua" \
+ LUA_LIBDIR="$(TARGET_DIR)/usr/lib/lua" install
+endef
+
+define XAVANTE_UNINSTALL_TARGET_CMDS
+ rm -rf "$(TARGET_DIR)/usr/share/xavante"
+ rm -f "$(TARGET_DIR)/usr/share/xavante.lua"
+ rm -f "$(TARGET_DIR)/usr/share/sajax.lua"
+endef
+
+$(eval $(call GENTARGETS,package,xavante))