summaryrefslogtreecommitdiffstats
path: root/package/wsapi
diff options
context:
space:
mode:
Diffstat (limited to 'package/wsapi')
-rw-r--r--package/wsapi/Config.in9
-rw-r--r--package/wsapi/wsapi.mk21
2 files changed, 30 insertions, 0 deletions
diff --git a/package/wsapi/Config.in b/package/wsapi/Config.in
new file mode 100644
index 000000000..362164848
--- /dev/null
+++ b/package/wsapi/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_WSAPI
+ bool "wsapi"
+ select BR2_PACKAGE_COXPCALL
+ select BR2_PACKAGE_LUAFILESYSTEM
+ select BR2_PACKAGE_RINGS
+ help
+ API that abstracts the web server from Lua web applications.
+
+ http://keplerproject.github.com/wsapi/
diff --git a/package/wsapi/wsapi.mk b/package/wsapi/wsapi.mk
new file mode 100644
index 000000000..c0f9c8bdb
--- /dev/null
+++ b/package/wsapi/wsapi.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# wsapi
+#
+#############################################################
+
+WSAPI_VERSION = 1.3.4
+WSAPI_SITE = http://github.com/downloads/keplerproject/wsapi
+WSAPI_DEPENDENCIES = coxpcall luafilesystem rings
+
+define WSAPI_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/usr/share/lua/wsapi
+ $(INSTALL) -m 0644 -D $(@D)/src/wsapi/*.lua \
+ $(TARGET_DIR)/usr/share/lua/wsapi
+endef
+
+define WSAPI_UNINSTALL_TARGET_CMDS
+ rm -rf "$(TARGET_DIR)/usr/share/lua/wsapi"
+endef
+
+$(eval $(call GENTARGETS,package,wsapi))