summaryrefslogtreecommitdiffstats
path: root/package/tcpdump
diff options
context:
space:
mode:
Diffstat (limited to 'package/tcpdump')
-rw-r--r--package/tcpdump/tcpdump.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
index e295e6902..81228169b 100644
--- a/package/tcpdump/tcpdump.mk
+++ b/package/tcpdump/tcpdump.mk
@@ -14,4 +14,11 @@ TCPDUMP_CONF_OPT:=--without-crypto \
$(if $(BR2_PACKAGE_TCPDUMP_SMB),--enable-smb,--disable-smb)
TCPDUMP_DEPENDENCIES:=zlib libpcap
+# make install installs an unneeded extra copy of the tcpdump binary
+define TCPDUMP_REMOVE_DUPLICATED_BINARY
+ rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
+endef
+
+TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY
+
$(eval $(call AUTOTARGETS,package,tcpdump))