summaryrefslogtreecommitdiffstats
path: root/package/sylpheed/sylpheed.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/sylpheed/sylpheed.mk')
-rw-r--r--package/sylpheed/sylpheed.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/sylpheed/sylpheed.mk b/package/sylpheed/sylpheed.mk
index 451c4de9a..32c0a82c9 100644
--- a/package/sylpheed/sylpheed.mk
+++ b/package/sylpheed/sylpheed.mk
@@ -9,11 +9,20 @@ SYLPHEED_VERSION = $(SYLPHEED_VERSION_MAJOR).$(SYLPHEED_VERSION_MINOR)
SYLPHEED_SOURCE = sylpheed-$(SYLPHEED_VERSION).tar.bz2
SYLPHEED_SITE = http://sylpheed.sraoss.jp/sylpheed/v$(SYLPHEED_VERSION_MAJOR)
-SYLPHEED_CONF_OPT = --disable-gtkspell \
- --includedir=$(STAGING_DIR)/usr/include
+SYLPHEED_CONF_OPT = --disable-gtkspell
SYLPHEED_DEPENDENCIES = host-pkg-config libgtk2
+# Remove the -I$(includedir) from the Makefiles
+# because it refers to the host /usr/include.
+define SYLPHEED_PRECONFIGURE
+ for i in $$(find $(@D) -name "Makefile*"); do \
+ sed -i 's:-I$$(includedir)::g' $$i; \
+ done
+endef
+
+SYLPHEED_PRE_CONFIGURE_HOOKS += SYLPHEED_PRECONFIGURE
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
SYLPHEED_DEPENDENCIES += openssl
SYLPHEED_CONF_OPT += --enable-ssl