summaryrefslogtreecommitdiffstats
path: root/package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch')
-rw-r--r--package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch b/package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch
new file mode 100644
index 000000000..33286ce39
--- /dev/null
+++ b/package/python3/python3-3.3-011-cross-compile-getaddrinfo.patch
@@ -0,0 +1,21 @@
+Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
+
+Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: Python-3.3.0/configure.ac
+===================================================================
+--- Python-3.3.0.orig/configure.ac
++++ Python-3.3.0/configure.ac
+@@ -3204,7 +3204,7 @@
+
+ AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
+
+-if test $have_getaddrinfo = no || test "$ac_cv_buggy_getaddrinfo" = yes
++if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
+ then
+ if test $ipv6 = yes
+ then