summaryrefslogtreecommitdiffstats
path: root/package/protobuf
diff options
context:
space:
mode:
Diffstat (limited to 'package/protobuf')
-rw-r--r--package/protobuf/Config.in11
-rw-r--r--package/protobuf/protobuf.mk21
2 files changed, 32 insertions, 0 deletions
diff --git a/package/protobuf/Config.in b/package/protobuf/Config.in
new file mode 100644
index 000000000..b044ef03c
--- /dev/null
+++ b/package/protobuf/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PROTOBUF
+ bool "protobuf"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Protocol buffers are Google's language-neutral, platform-neutral,
+ extensible mechanism for serializing structured data.
+
+ http://code.google.com/p/protobuf/
+
+comment "protobuf requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
new file mode 100644
index 000000000..f18261e1e
--- /dev/null
+++ b/package/protobuf/protobuf.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# protobuf
+#
+#############################################################
+PROTOBUF_VERSION = 2.4.1
+PROTOBUF_SOURCE = protobuf-$(PROTOBUF_VERSION).tar.gz
+PROTOBUF_SITE = http://protobuf.googlecode.com/files/
+
+# N.B. Need to use host protoc during cross compilation.
+PROTOBUF_DEPENDENCIES = host-protobuf
+PROTOBUF_CONF_OPT = --with-protoc=$(HOST_DIR)/usr/bin/protoc
+
+PROTOBUF_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+PROTOBUF_DEPENDENCIES += zlib
+endif
+
+$(eval $(call AUTOTARGETS))
+$(eval $(call AUTOTARGETS,host))