summaryrefslogtreecommitdiffstats
path: root/package/proftpd
diff options
context:
space:
mode:
Diffstat (limited to 'package/proftpd')
-rw-r--r--package/proftpd/Config.in6
-rw-r--r--package/proftpd/proftpd.mk4
2 files changed, 10 insertions, 0 deletions
diff --git a/package/proftpd/Config.in b/package/proftpd/Config.in
index abdedc9e5..779371347 100644
--- a/package/proftpd/Config.in
+++ b/package/proftpd/Config.in
@@ -4,3 +4,9 @@ config BR2_PACKAGE_PROFTPD
ProFTPD, a highly configurable FTP server.
http://www.proftpd.org/
+
+config BR2_PACKAGE_PROFTPD_MOD_REWRITE
+ bool "mod_rewrite support"
+ depends on BR2_PACKAGE_PROFTPD
+ help
+ Compile ProFTPD with mod_rewrite support
diff --git a/package/proftpd/proftpd.mk b/package/proftpd/proftpd.mk
index 1d02194b9..92644a80a 100644
--- a/package/proftpd/proftpd.mk
+++ b/package/proftpd/proftpd.mk
@@ -20,6 +20,10 @@ PROFTPD_CONF_OPT = --localstatedir=/var/run \
--enable-shadow \
--with-gnu-ld
+ifeq ($(BR2_PACKAGE_PROFTPD_MOD_REWRITE),y)
+PROFTPD_CONF_OPT += --with-modules=mod_rewrite
+endif
+
define PROFTPD_MAKENAMES
$(MAKE1) CC="$(HOSTCC)" CFLAGS="" LDFLAGS="" -C $(@D)/lib/libcap _makenames
endef