summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index b55b5f0b4..56fca6be8 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -508,9 +508,7 @@ ifeq ($(call qstrip,$$($(2)_LICENSE_FILES)),)
@$(call legal-license-nofiles,$$($(2)_RAWNAME))
@$(call legal-warning-pkg,$$($(2)_RAWNAME),cannot save license ($(2)_LICENSE_FILES not defined))
else
- @for F in $$($(2)_LICENSE_FILES); do \
- $(call legal-license-file,$$($(2)_RAWNAME),$$$${F},$$($(2)_DIR)/$$$${F}); \
- done
+ @$(foreach F,$($(2)_LICENSE_FILES),$(call legal-license-file,$$($(2)_RAWNAME),$(F),$$($(2)_DIR)/$(F))$$(sep))
endif
ifeq ($$($(2)_REDISTRIBUTE),YES)
# Copy the source tarball (just hardlink if possible)