summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 59de0f0d1..19a115ecd 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -128,6 +128,13 @@ $(BUILD_DIR)/%/.stamp_staging_installed:
@$(call MESSAGE,"Installing to staging directory")
$($(PKG)_INSTALL_STAGING_CMDS)
$(foreach hook,$($(PKG)_POST_INSTALL_STAGING_HOOKS),$(call $(hook))$(sep))
+ $(Q)if test -n "$($(PKG)_CONFIG_FIXUP)" ; then \
+ $(call MESSAGE,"Fixing package configuration files") ;\
+ $(SED) "s,^\(exec_\)\?prefix=.*,\1prefix=$(STAGING_DIR)/usr,g" \
+ -e "s,-I/usr/,-I$(STAGING_DIR)/usr/,g" \
+ -e "s,-L/usr/,-L$(STAGING_DIR)/usr/,g" \
+ $(addprefix $(STAGING_DIR)/usr/bin/,$($(PKG)_CONFIG_FIXUP)) ;\
+ fi
$(Q)touch $@
# Install to images dir