summaryrefslogtreecommitdiffstats
path: root/package/pkg-autotargets.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-autotargets.mk')
-rw-r--r--package/pkg-autotargets.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/pkg-autotargets.mk b/package/pkg-autotargets.mk
index d31230dd7..d925cbb46 100644
--- a/package/pkg-autotargets.mk
+++ b/package/pkg-autotargets.mk
@@ -305,10 +305,5 @@ endef
# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
-define AUTOTARGETS
-ifeq ($(1),host)
-$(call AUTOTARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
-else
-$(call AUTOTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
-endif
-endef
+AUTOTARGETS = $(call AUTOTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+host-autotools-package = $(call AUTOTARGETS_INNER,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)