summaryrefslogtreecommitdiffstats
path: root/package/perl
diff options
context:
space:
mode:
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/Config.in6
-rw-r--r--package/perl/perl.mk3
2 files changed, 9 insertions, 0 deletions
diff --git a/package/perl/Config.in b/package/perl/Config.in
index 6cb89f029..98b41da4f 100644
--- a/package/perl/Config.in
+++ b/package/perl/Config.in
@@ -22,6 +22,12 @@ config BR2_PACKAGE_PERL_DB_FILE
help
Build the DB_File module.
+config BR2_PACKAGE_PERL_GDBM_FILE
+ bool "GDBM_File"
+ select BR2_PACKAGE_GDBM
+ help
+ Build the GDBM_File module.
+
endif
comment "perl requires an architecture supported by qemu"
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 186158bf2..56abbc1f1 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -16,6 +16,9 @@ PERL_DEPENDENCIES = host-qemu
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
PERL_DEPENDENCIES += berkeleydb
endif
+ifeq ($(BR2_PACKAGE_GDBM),y)
+ PERL_DEPENDENCIES += gdbm
+endif
PERL_CONF_OPT = -des \
-Dusecrosscompile \