summaryrefslogtreecommitdiffstats
path: root/package/pcre/pcre.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pcre/pcre.mk')
-rw-r--r--package/pcre/pcre.mk17
1 files changed, 1 insertions, 16 deletions
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
index 9e27cb52c..48266ff74 100644
--- a/package/pcre/pcre.mk
+++ b/package/pcre/pcre.mk
@@ -9,26 +9,11 @@ PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
PCRE_LICENSE = BSD-3c
PCRE_LICENSE_FILES = LICENCE
PCRE_INSTALL_STAGING = YES
+PCRE_CONFIG_SCRIPTS = pcre-config
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
# pcre will use the host g++ if a cross version isn't available
PCRE_CONF_OPT = --disable-cpp
endif
-define PCRE_STAGING_PCRE_CONFIG_FIXUP
- $(SED) 's,^prefix=.*,prefix=$(STAGING_DIR)/usr,' \
- -e 's,^exec_prefix=.*,exec_prefix=$(STAGING_DIR)/usr,' \
- $(STAGING_DIR)/usr/bin/pcre-config
-endef
-
-PCRE_POST_INSTALL_STAGING_HOOKS += PCRE_STAGING_PCRE_CONFIG_FIXUP
-
-define PCRE_TARGET_REMOVE_PCRE_CONFIG
- rm -f $(TARGET_DIR)/usr/bin/pcre-config
-endef
-
-ifneq ($(BR2_HAVE_DEVFILES),y)
-PCRE_POST_INSTALL_TARGET_HOOKS += PCRE_TARGET_REMOVE_PCRE_CONFIG
-endif
-
$(eval $(autotools-package))