summaryrefslogtreecommitdiffstats
path: root/package/opus
diff options
context:
space:
mode:
Diffstat (limited to 'package/opus')
-rw-r--r--package/opus/Config.in15
-rw-r--r--package/opus/opus.mk16
2 files changed, 31 insertions, 0 deletions
diff --git a/package/opus/Config.in b/package/opus/Config.in
new file mode 100644
index 000000000..12bdfbbdb
--- /dev/null
+++ b/package/opus/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_OPUS
+ bool "opus"
+ help
+ The Opus codec is designed for interactive speech and audio
+ transmission over the Internet. It is designed by the IETF
+ Codec Working Group and incorporates technology from Skype's
+ SILK codec and Xiph.Org's CELT codec.
+
+ It is intended to suit a wide range of interactive audio
+ applications, including Voice over IP, videoconferencing,
+ in-game chat, and even remote live music performances. It
+ can scale from low bit-rate narrowband speech to very high
+ quality stereo music.
+
+ http://opus-codec.org
diff --git a/package/opus/opus.mk b/package/opus/opus.mk
new file mode 100644
index 000000000..177adfb09
--- /dev/null
+++ b/package/opus/opus.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# opus
+#
+#############################################################
+
+OPUS_VERSION = 1.0.1
+OPUS_SITE = http://downloads.xiph.org/releases/opus
+OPUS_INSTALL_STAGING = YES
+OPUS_CONF_OPT = --disable-doc
+
+ifeq ($(BR2_SOFT_FLOAT),y)
+OPUS_CONF_OPT += --enable-fixed-point
+endif
+
+$(eval $(autotools-package))