summaryrefslogtreecommitdiffstats
path: root/package/on2-8170-modules
diff options
context:
space:
mode:
Diffstat (limited to 'package/on2-8170-modules')
-rw-r--r--package/on2-8170-modules/Config.in11
-rw-r--r--package/on2-8170-modules/on2-8170-modules.mk23
2 files changed, 34 insertions, 0 deletions
diff --git a/package/on2-8170-modules/Config.in b/package/on2-8170-modules/Config.in
new file mode 100644
index 000000000..18c066e99
--- /dev/null
+++ b/package/on2-8170-modules/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ON2_8170_MODULES
+ bool "on2-8170 modules"
+ depends on BR2_LINUX_KERNEL
+ depends on BR2_arm926t
+ help
+ Kernel modules for Hantro x170 hardware video decompression support.
+
+ http://www.at91.com/linux4sam/bin/view/Linux4SAM/SAM9M10Gstreamer
+
+comment "on2-8170 modules requires a linux kernel to be built"
+ depends on !BR2_LINUX_KERNEL
diff --git a/package/on2-8170-modules/on2-8170-modules.mk b/package/on2-8170-modules/on2-8170-modules.mk
new file mode 100644
index 000000000..800abc774
--- /dev/null
+++ b/package/on2-8170-modules/on2-8170-modules.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# on2-8170-modules
+#
+################################################################################
+
+ON2_8170_MODULES_VERSION = 73b0806
+ON2_8170_MODULES_SITE = http://github.com/alexandrebelloni/on2-8170-modules/tarball/$(ON2_8170_MODULES_VERSION)
+
+ON2_8170_MODULES_DEPENDENCIES = linux
+
+ON2_8170_MODULES_LICENSE = GPLv2+
+#There is no license file
+
+define ON2_8170_MODULES_BUILD_CMDS
+ $(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D)
+endef
+
+define ON2_8170_MODULES_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D) modules_install
+endef
+
+$(eval $(generic-package))