summaryrefslogtreecommitdiffstats
path: root/package/nmap
diff options
context:
space:
mode:
Diffstat (limited to 'package/nmap')
-rw-r--r--package/nmap/Config.in16
-rw-r--r--package/nmap/nmap.mk24
2 files changed, 40 insertions, 0 deletions
diff --git a/package/nmap/Config.in b/package/nmap/Config.in
new file mode 100644
index 000000000..be1be33db
--- /dev/null
+++ b/package/nmap/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_NMAP
+ bool "nmap"
+ depends on BR2_INET_IPV6
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU # fork()
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_LIBPCAP
+ select BR2_PACKAGE_PCRE
+ help
+ Nmap ("Network Mapper") is a free and open source (license)
+ utility for network discovery and security auditing.
+
+ http://nmap.org
+
+comment "nmap requires a toolchain with C++, IPV6 and thread support"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_TOOLCHAIN_HAS_THREADS)
diff --git a/package/nmap/nmap.mk b/package/nmap/nmap.mk
new file mode 100644
index 000000000..a5b085d7f
--- /dev/null
+++ b/package/nmap/nmap.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# nmap
+#
+#############################################################
+
+NMAP_VERSION = 6.01
+NMAP_SITE = http://nmap.org/dist
+NMAP_SOURCE = nmap-$(NMAP_VERSION).tar.bz2
+NMAP_DEPENDENCIES = libpcap pcre
+NMAP_CONF_OPT = --without-liblua --without-zenmap \
+ --with-libdnet=included --with-liblinear=included \
+ --with-libpcre="$(STAGING_DIR)/usr"
+NMAP_LICENSE = GPLv2
+NMAP_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+NMAP_CONF_OPT += --with-openssl="$(STAGING_DIR)/usr"
+NMAP_DEPENDENCIES += openssl
+else
+NMAP_CONF_OPT += --without-openssl
+endif
+
+$(eval $(autotools-package))